Bug 32530 - kernel oops
kernel oops
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 09:41 EST by Henri Schlereth
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 11:46:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-03-21 09:41:09 EST
kernel 2.4.2-0.1.19 i586

Mar 21 04:02:19 rock kernel: Unable to handle kernel NULL pointer dereference at virtual address 00000004
Mar 21 04:02:19 rock kernel:  printing eip:
Mar 21 04:02:19 rock kernel: c014619b
Mar 21 04:02:19 rock kernel: pgd entry c0942000: 0000000000000000
Mar 21 04:02:19 rock kernel: pmd entry c0942000: 0000000000000000
Mar 21 04:02:19 rock kernel: ... pmd not present!
Mar 21 04:02:19 rock kernel: Oops: 0000
Mar 21 04:02:19 rock kernel: CPU:    0
Mar 21 04:02:19 rock kernel: EIP:    0010:[clear_inode+219/304]
Mar 21 04:02:19 rock kernel: EIP:    0010:[<c014619b>]
Mar 21 04:02:19 rock kernel: EFLAGS: 00010202
Mar 21 04:02:19 rock kernel: eax: 00000000   ebx: c0bd1e00   ecx: c0bd1e08   edx: 00000004
Mar 21 04:02:19 rock kernel: esi: c16c5f84   edi: 00002091   ebp: c16c5f98   esp: c16c5f50

machine template

Machine ID/name: #2/rock

CPU: Intel Pentium 100 1
Memory: 65MB 1
Motherboard: N/A 1
Video: Trident Microsystems 3DIm`age 975 (rev f3) 5
Storage: Quantum Fireball EX6.4a ATA 6149MB 1
         Quantum Fireball Ct10 05 ATA 4884MB 1
         TEAC CD-W54E (CD-RW) 1
         IOMEGA ZIP 100 ATAPI, ATAPI FLOPPY DRIVE 1
Network: 3c503 Etherlink II-TP ISA 2
Sound:   Creative Labs SoundBlaster 16/DSP 2 * 

lspci:

00:00.0 Host bridge: Intel Corporation 430FX - 82437FX TSC [Triton I] (rev 02)
00:07.0 ISA bridge: Intel Corporation 82371FB PIIX ISA [Triton I] (rev 02)
00:07.1 IDE interface: Intel Corporation 82371FB PIIX IDE [Triton I] (rev 02)
00:09.0 VGA compatible controller: Trident Microsystems 3DIm`age 975 (rev f3)

lspci -n:

00:00.0 Class 0600: 8086:122d (rev 02)
00:07.0 Class 0601: 8086:122e (rev 02)
00:07.1 Class 0101: 8086:1230 (rev 02)
00:09.0 Class 0300: 1023:9750 (rev f3)


Mar 21 04:02:19 rock kernel: ds: 0018   es: 0018   ss: 0018
Mar 21 04:02:19 rock kernel: Process kswapd (pid: 3, stackpage=c16c5000)
Mar 21 04:02:19 rock kernel: Stack: c0bd1e00 c0145a30 c166d0c0 c0bd1c20 c0bd1c20 c0bd1e00 c0146228 c0bd1e00 
Mar 21 04:02:19 rock kernel:        c0be6ba8 c0be6ba0 c014646e c16c5f84 0000016a c0bd0048 c0b7c268 00010f00 
Mar 21 04:02:19 rock kernel:        00000004 00000034 00000004 c01464b5 00000000 c012c806 00000006 00000004 
Mar 21 04:02:19 rock kernel: Call Trace: [destroy_inode+48/64] [dispose_list+56/96] [prune_icache+254/272] [shrink_icache_memory+53/80] 
[do_try_to_free_pages+102/128] [kswapd+112/272] [empty_bad_page+0/4096] 
Mar 21 04:02:19 rock kernel: Call Trace: [<c0145a30>] [<c0146228>] [<c014646e>] [<c01464b5>] [<c012c806>] [<c012c890>] [<c0105000>] 
Mar 21 04:02:19 rock kernel:        [empty_bad_page+0/4096] [kernel_thread+38/48] [kswapd+0/272] 
Mar 21 04:02:19 rock kernel:        [<c0105000>] [<c01074b6>] [<c012c820>] 
Mar 21 04:02:19 rock kernel: 
Mar 21 04:02:19 rock kernel: Code: ff 50 04 59 8b 83 90 00 00 00 85 c0 74 12 8b 40 20 85 c0 74 
Mar 21 04:02:19 rock kernel: kernel BUG at exit.c:465!
Mar 21 04:02:19 rock kernel: invalid operand: 0000
Mar 21 04:02:19 rock kernel: CPU:    0
Mar 21 04:02:19 rock kernel: EIP:    0010:[do_exit+560/576]

ksymoops output (note warnings can be ignored because system had to be rebooted.)

ksymoops 2.4.0 on i586 2.4.2-0.1.19.  Options used
     -v /boot/vmlinux-2.4.2-0.1.19 (specified)
     -k /proc/ksyms (default)
     -l /proc/modules (default)
     -o /lib/modules/2.4.2-0.1.19/ (default)
     -m /boot/System.map-2.4.2-0.1.19 (default)

Warning (compare_maps): ksyms_base symbol __VERSIONED_SYMBOL(shmem_file_setup) not found in vmlinux.  Ignoring ksyms_base 
entry
Warning (compare_maps): mismatch on symbol partition_name  , ksyms_base says c01b0130, vmlinux says c01524c0.  Ignoring ksyms_base 
entry
Mar 21 04:02:19 rock kernel: Unable to handle kernel NULL pointer dereference at virtual address 00000004
Mar 21 04:02:19 rock kernel: c014619b
Mar 21 04:02:19 rock kernel: Oops: 0000
Mar 21 04:02:19 rock kernel: CPU:    0
Mar 21 04:02:19 rock kernel: EIP:    0010:[clear_inode+219/304]
Mar 21 04:02:19 rock kernel: EIP:    0010:[<c014619b>]
Using defaults from ksymoops -t elf32-i386 -a i386
Mar 21 04:02:19 rock kernel: EFLAGS: 00010202
Mar 21 04:02:19 rock kernel: eax: 00000000   ebx: c0bd1e00   ecx: c0bd1e08   edx: 00000004
Mar 21 04:02:19 rock kernel: esi: c16c5f84   edi: 00002091   ebp: c16c5f98   esp: c16c5f50
Mar 21 04:02:19 rock kernel: ds: 0018   es: 0018   ss: 0018
Mar 21 04:02:19 rock kernel: Process kswapd (pid: 3, stackpage=c16c5000)
Mar 21 04:02:19 rock kernel: Stack: c0bd1e00 c0145a30 c166d0c0 c0bd1c20 c0bd1c20 c0bd1e00 c0146228 c0bd1e00 
Mar 21 04:02:19 rock kernel:        c0be6ba8 c0be6ba0 c014646e c16c5f84 0000016a c0bd0048 c0b7c268 00010f00 
Mar 21 04:02:19 rock kernel:        00000004 00000034 00000004 c01464b5 00000000 c012c806 00000006 00000004 
Mar 21 04:02:19 rock kernel: Call Trace: [destroy_inode+48/64] [dispose_list+56/96] [prune_icache+254/272] [shrink_icache_memory+53/80] 
[do_try_to_free_pages+102/128] [kswapd+112/272] [empty_bad_page+0/4096] 
Mar 21 04:02:19 rock kernel: Call Trace: [<c0145a30>] [<c0146228>] [<c014646e>] [<c01464b5>] [<c012c806>] [<c012c890>] [<c0105000>] 
Mar 21 04:02:19 rock kernel:        [<c0105000>] [<c01074b6>] [<c012c820>] 
Mar 21 04:02:19 rock kernel: Code: ff 50 04 59 8b 83 90 00 00 00 85 c0 74 12 8b 40 20 85 c0 74 

>>EIP; c014619b <clear_inode+db/130>   <=====
Trace; c0145a30 <destroy_inode+30/40>
Trace; c0146228 <dispose_list+38/60>
Trace; c014646e <prune_icache+fe/110>
Trace; c01464b5 <shrink_icache_memory+35/50>
Trace; c012c806 <do_try_to_free_pages+66/80>
Trace; c012c890 <kswapd+70/110>
Trace; c0105000 <empty_bad_page+0/1000>
Trace; c0105000 <empty_bad_page+0/1000>
Trace; c01074b6 <kernel_thread+26/30>
Trace; c012c820 <kswapd+0/110>
Code;  c014619b <clear_inode+db/130>
00000000 <_EIP>:
Code;  c014619b <clear_inode+db/130>   <=====
   0:   ff 50 04                  call   *0x4(%eax)   <=====
Code;  c014619e <clear_inode+de/130>
   3:   59 pop    %ecx
Code;  c014619f <clear_inode+df/130>
   4:   8b 83 90 00 00 00         mov    0x90(%ebx),%eax
Code;  c01461a5 <clear_inode+e5/130>
   a:   85 c0                     test   %eax,%eax
Code;  c01461a7 <clear_inode+e7/130>
   c:   74 12                     je     20 <_EIP+0x20> c01461bb <clear_inode+fb/130>
Code;  c01461a9 <clear_inode+e9/130>
   e:   8b 40 20                  mov    0x20(%eax),%eax
Code;  c01461ac <clear_inode+ec/130>
  11:   85 c0                     test   %eax,%eax
Code;  c01461ae <clear_inode+ee/130>
  13:   74 00                     je     15 <_EIP+0x15> c01461b0 <clear_inode+f0/130>

Mar 21 04:02:19 rock kernel: kernel BUG at exit.c:465!
Mar 21 04:02:19 rock kernel: invalid operand: 0000
Mar 21 04:02:19 rock kernel: CPU:    0
Mar 21 04:02:19 rock kernel: EIP:    0010:[do_exit+560/576]

2 warnings issued.  Results may not be reliable.
Comment 1 Arjan van de Ven 2001-03-27 10:59:42 EST
What kind of filesystems are you using?
ext2 only?
Comment 2 Henri Schlereth 2001-03-27 11:46:04 EST
No this a dual-boot RHL/Win98 box so I also have vfat and fat going.
Comment 3 Henri Schlereth 2001-09-18 08:00:22 EDT
The errata kernel seems to have fixed this.

Note You need to log in before you can comment on or make changes to this bug.