Bug 32539 - glibc 2.2.2-7 will not build on sparc64
Summary: glibc 2.2.2-7 will not build on sparc64
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: sparc Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-21 16:45 UTC by Jason Duerstock
Modified: 2016-11-24 15:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 19:10:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Duerstock 2001-03-21 16:45:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


glibc 2.2.2-7 will not build on sparc64

Reproducible: Always
Steps to Reproduce:
1. rpm -ba glibc-2.2.2-7.src.rpm
2. cd /usr/src/redhat
3. rpm -ba SPECS/glibc.rpm
	

Actual Results:  make[2]: Entering directory `/usr/src/redhat/BUILD/glibc-
2.2.2/string'
../sysdeps/sparc/sparc64/strcat.S: Assembler messages:
../sysdeps/sparc/sparc64/strcat.S:73: Error: Illegal operands: invalid ASI 
expression
../sysdeps/sparc/sparc64/strcat.S:114: Error: Illegal operands: invalid 
ASI expression
../sysdeps/sparc/sparc64/strcat.S:151: Error: Illegal operands: invalid 
ASI expression
../sysdeps/sparc/sparc64/strcat.S:230: Error: Illegal operands: invalid 
ASI expression
../sysdeps/sparc/sparc64/strcat.S:244: Error: Illegal operands: invalid 
ASI expression
../sysdeps/sparc/sparc64/strcat.S:262: Error: Illegal operands: invalid 
ASI expression
../sysdeps/sparc/sparc64/strcat.S:266: Error: Illegal operands: invalid 
ASI expression
make[2]: *** [/usr/src/redhat/BUILD/glibc-2.2.2/build-sparc64-
linux/string/strcat.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.2.2/string'
make[1]: *** [string/subdir_lib] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.2.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.35603 (%build)

Expected Results:  a working glibc-2.2.2-7.sparc64.rpm

this is on a sparc ultra5

Comment 1 Jakub Jelinek 2001-03-22 11:51:42 UTC
It builds just fine (just tried it), but:
you either want to build a 32bit glibc, then do:
sparc32 rpm -ba -v glibc.spec
or (32bit glibc which will run on UltraSPARC only):
sparc32 rpm -ba -v --target=sparcv9-linux glibc.spec
or you want to build 64bit glibc, but then you should make sure you have
64bit toolchain ready - rpm -ba -v glibc.spec will build a 64bit glibc.
From the above messages it looks like you don't have 64bit toolchain in place,
or have wrong kernel headers (/usr/include/asm must be a directory with little
headers which either include asm-sparc/xy.h or asm-sparc64/xy.h depending on
preprocessor macros).

Comment 2 Jason Duerstock 2001-03-22 19:10:24 UTC
The command used to assemble this file was:
as -Av9a -Qy -s -Av9a -64 -no-undeclared-regs -relax -
o /usr/src/redhat/BUILD/glibc-2.2.2/build-sparc64-
linux/string/strcat.o /tmp/cc68c0rr.s

Is this not enough to produce sparc64 binaries?


Comment 3 Jason Duerstock 2001-05-25 15:19:25 UTC
glibc will now build using
rpm --target=sparc64 -ba SPECS/glibc.spec




Note You need to log in before you can comment on or make changes to this bug.