Bug 32541 - Installer crashed while formatting the Linux Native partition, and rearranged the partition table
Installer crashed while formatting the Linux Native partition, and rearranged...
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-21 12:27 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-10 18:07:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-21 12:27:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

I have a Dual-Boot system between Windows 95 and a Linux system. I 
attempted to install Red Hat 7 on my Linux partition, and using the text 
installer, everything went fine up until the point where it started 
formatting the partition. It took an ungodly amount of time to format 
(Over 40 minutes), so I rebooted. I tried installing it again, and it 
crashed while formatting. (I neglected to save the output, because I 
didn't know I was able to report it.) So I rebooted, and tried to install 
it a third time. During the install, only 3 packages were listed: GNOME, 
KDE, and Games. I watched it start to install, and it said that it was 
formatting the /dev/hda6 partition - Except I never had a /dev/hda6 
partition. My table was laid out like this:

/dev/hda1 - Linux Native, 9GB
/dev/hda2 - Linux Swap, 250MB
/dev/hda3 - Windows FAT32 DMA, 10GB
/dev/hda4 - Windows FAT32 DMA, 2GB

I didn't change ANY partitions in the installer, and it rearranged 
everything. /dev/hda3 is now /dev/hda5, and in Windows, what used to be D: 
is now G:, and D: is no longer accessable. 

RH7 never managed to complete a full install, and my partition table is 

Reproducible: Didn't try
Steps to Reproduce:
My system still kinda works after this fiasco. I dare not try again.

My computer is a Pentium III 500, with 256MB Ram, running on an Intel 
SE440BX2 Motherboard.

Internal Cards include: NE2000 Network Card, 3dfx Voodoo3 2000 AGP, 
Ensoniq SoundScape Vivo90, and a RealMagic Hollywood Plus.

/dev/hda is a 30GB Western Digital hard drive. There are two Toshiba 
optical drives - One is a 20X Toshiba CDROM, the other is a Toshiba 9x DVD-
Comment 1 Michael Fulbright 2001-03-21 13:59:29 EST
Sounds like your drive was having problems, would have been interesting to know
what was popping out on VC4. Usually sense errors would come up in a case like this.

If you try again please look on VC4 when you start seeing strange behavior and
see if there are any kernel errors.
Comment 2 Brent Fox 2001-04-10 18:07:05 EDT
Closing due to inactivity. Please reopen if you have any more info.

Note You need to log in before you can comment on or make changes to this bug.