Bug 32566 - Unable to have new adaptec driver statically linked to kernel
Unable to have new adaptec driver statically linked to kernel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 15:26 EST by Bryan Leopard
Modified: 2010-10-27 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-26 17:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-03-21 15:26:55 EST
New adaptec driver is using different name than traditional 
name "aic7xxx.o". This will confuse the proccess making bzImage and other 
utility such as mkinird. When trying to make kernel image with static 
adaptec driver, It will not pick up new adaptec driver. "mkinitrd" will 
also fail because modules.conf file reference aic7xxx instead a new driver 
named aic7xxx_mod.o. 

H/W:
All system with adaptec controller

S/W: 
Redhat 7.1 RC2 with 2.4.2-0.1.19 kernel

Steps:
Static driver failure -
1. install OS
2. open menuconfig and choose static driver option on new adaptec
3. run make bzImage
4. reboot from rebuilt kernel.
5. after reboot, go to /proc/driver/scsi to verify the driver loaded

mkinitrd failure -
1. install OS
2. open menuconfig choose adaptec driver as module
3. compile and install the kernel
4. make and install modules
5. run mkinitrd
Comment 1 Michael K. Johnson 2001-03-26 17:05:17 EST
If I read this right, this is simply not a bug.  Doug?
Comment 2 Doug Ledford 2001-03-26 18:14:19 EST
There are several issues here:

1) New adaptec driver doesn't use name aic7xxx.  Not a bug, a specific
requirement of the kernel team at Red Hat.  It was felt that the new aic7xxx
driver (which can be found in the kernel rpm as aic7xxx_new and in the list of
available modules at install time as New Adaptec 274x ... driver) did not yet
have enough test time to take over the default driver position.

2) Name issue will confuse utilities such as mkinitrd.  Not true.  The existing
aic7xxx driver is the old aic7xxx driver, and it is still present and mkinitrd
works just fine with it.  To use the new driver instead of the old one, make
modules.conf have an alias for aic7xxx_new instead and it will work just fine
with the new driver.

3) New Adaptec driver did not get statically linked into the kernel during a
make bzImage process.  Known bug, already fixed.  The top level Makefile is
responsible for linking aic7xxx_drv.o into the kernel when statically configured
and it does in recent kernel RPMs.

4) Mkinitrd will fail because aic7xxx_mod.o is not referrenced in modules.conf. 
The new aic7xxx driver has a Makefile that changes the drivers name at the time
that it is loaded into the module directory
(/lib/modules/*/kernel/drivers/scsi/) and so putting aic7xxx_mod.o into the
modules.conf file would cause mkinitrd to look for a nonexistant file and fail
(the file is actuall installed as aic7xxx_new.o in our kernel tree).

I'm closing this bug out.  What items are actual bugs have already been fixed
and will show up in Rawhide, the rest are not bugs.

Note You need to log in before you can comment on or make changes to this bug.