Bug 32572 - Change to terminfo database to reflect 'screen' terminal BackSpace key changes
Change to terminfo database to reflect 'screen' terminal BackSpace key changes
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
: FutureFeature
Depends On:
Blocks: 38957
  Show dependency treegraph
 
Reported: 2001-03-21 16:04 EST by dan
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 11:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to terminfo database to reflect 'screen' terminal BS key change (635 bytes, patch)
2001-03-21 16:06 EST, dan
no flags Details | Diff

  None (edit)
Description dan 2001-03-21 16:04:41 EST
I propose a change to terminfo database related to BackSpace key generated
character change. For 'screen' terminal there has been still obsolete
'kbs=^H' definition in terminfo database leading to necessity of various
hacks to make screen work correctly. I've changed 'kbs=^H' into 'kbs=\177'
in 'screen' terminal entry of terminfo database source. Attached patch
makes screen hacks unneeded.
Comment 1 dan 2001-03-21 16:06:42 EST
Created attachment 13287 [details]
Patch to terminfo database to reflect 'screen' terminal BS key change
Comment 2 Bernhard Rosenkraenzer 2001-05-02 11:59:58 EDT
This breaks things rather than fixing them.
Try adding your patch to ncurses, then running the kernel's make menuconfig in 
a screen session, and using backspace when inputting a value. Works without 
the patch, but not with it.
Comment 3 dan 2001-05-03 07:48:58 EDT
I've noticed previously that along with applying the proposed patch to ncurses
package the "Red Hat Hack" patch could (and should) be removed from screen
package. So in fact this is a complex enhancement change regarding two packages
(ncurses and screen). If necessary, I could open corresponding bug for screen
package.
Comment 4 David Balažic 2001-07-26 05:42:20 EDT
Someone please close this as NOTABUG.

The cause of this situation is a bug in the screen program. The bug is pretty 
old and still not fixed ( as of screen 3.9.9 ). The bug is that for a certain 
key screen fails to convert the physical code ( as received from the physical 
terminal ) to the screen virtual terminal code ( as sent by the screen program 
to an application running in a screen virtual terminal ). This key is the 
backspace key. The screen man page and the screen terminfo/termcap ( both the 
one from http://www.tuxedo.org/terminfo and the on distributed with screen ) 
say that the backspace code from the physical terminal is converted to the code 
^H in the virtual terminal. The redhat hack is in fact a correct fix for this 
bug.

Your patch would just migrate the problem from physical terminals that send ^? 
for backspace to the ones that send ^H ( because screen would pass that code 
through instead of converting, due to the discussed bug )

Note You need to log in before you can comment on or make changes to this bug.