Bug 326 - Missing file halts network startup procedure
Missing file halts network startup procedure
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
5.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-07 07:17 EST by verm
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-09 14:44:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description verm 1998-12-07 07:17:22 EST
When the file /etc/redhat-release is missing, the network
startup procedure will halt on a script called
/etc/sysconfig/network-scripts/ifup-routes
No error message is given.
The problem is that the program linuxconf, which is called
in this script, needs this file. When
	linuxconf --hint routing "$1"
is started manually, it gives an error message.
I solved the problem by recreating the file redhat-release.
However, there seems to be no necessity for linuxconf to
halt on the nonexistence of this file, so doing so should be
seen as a bug in linuxconf.
Comment 1 Jay Turner 1998-12-08 17:06:59 EST
Yes, if the redhat-release file is missing, then the startup of
linuxconf will indeed fail.  Unable to replicate this file not getting
created however.  Need more information about the circumstances
surrounding this error, i.e. which type of install are you doing,
where in the install is the problem occurring?
Comment 2 David Lawrence 1998-12-09 14:44:59 EST
Linuxconf does indeed fail if the redhat-release file is missing, and
this is as a result of the dependance of Linuxconf on the file.  This
is by design.  Let us know if there are situations where the
redhat-release file is not getting created.

Note You need to log in before you can comment on or make changes to this bug.