Bug 326071 - initscript dependency on haldaemon
initscript dependency on haldaemon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 06:21 EDT by Felix Bellaby
Modified: 2008-02-11 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 22:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Bellaby 2007-10-10 06:21:22 EDT
Package versions:
NetworkManager-0.7.0-0.3.svn2914.fc8
hal-0.5.10-0.git20070925.fc8

NetworkManager has a dependency on haldaemon that is not reflected 
in the chkconfig start order, which is 98 in both initscripts. 

As a result, S98NetworkManager is run before S98haldaemon and the NetworkManager
daemon can die after reporting that it can not contact the hald.

changing the chkconfig initscript orders might be difficult because they so
needlessly congested, but the bug could be resolved using a kludge by renaming
the initscript to /etc/init.d/networkmanager
Comment 1 Dan Williams 2008-02-11 22:47:05 EST
This is fixed in F8/rawhide with the new-style LSB initscript ordering.

Note You need to log in before you can comment on or make changes to this bug.