Bug 32638 - unable to load pcmciadd.img on laptop with only an ls120
unable to load pcmciadd.img on laptop with only an ls120
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 22:33 EST by Scott Schmit
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 17:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Schmit 2001-03-21 22:33:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686; Nav)


The installer is unable to load the pcmciadd.img in a pcmcia install
because my laptop does not have a normal floppy drive, but rather only an
ls120. So the installer attempts to read from fd0 three times and fails
with "unable to mount..." The ls120 is properly detected however.

Reproducible: Always
Steps to Reproduce:
1. Find a laptop machine with only an ls120 that can serve as a boot drive
2. Boot the pcmcia.img image
3. Attempt to load the pcmciadd.img image

	

Actual Results:  "Unable to mount image" (or similar)

Expected Results:  It should have been able to mount the image, since the
disk was valid (tested on another linux machine). This is likely because
either fd0 isn't correctly accessing the ls120, or anaconda should try
reading from the ls120 if it detects one instead.

This is from a rawhide install, but I believe the problem also occurred
during a wolverine install as well (I can't be sure because there were
hardware issues with the dvd-rom/ls120 module on the laptop at the time
(since fixed)). Regardless, the bug does exist in rawhide.
Comment 1 Scott Schmit 2001-03-21 23:01:10 EST
I should add that this makes it impossible to create a boot disk as well.
Comment 2 Michael Fulbright 2001-03-22 10:40:43 EST
Brent please investigate.
Comment 3 Brent Fox 2001-03-22 14:18:32 EST
I've done extensive testing on LS-120 only systems, but they were all desktops.
 I'll have to see if we have such a laptop in house to test...Putting the bug in
to NEEDINFO state until I can find a laptop.
Comment 4 Brent Fox 2001-03-23 15:09:37 EST
I talked to the guys in the test lab, and we don't have a laptop with an LS120
drive, so I don't really have a way to reproduce this and try to fix it.  This
may get deferred to a future release.
Comment 5 Brent Fox 2001-03-23 23:47:40 EST
Deferring.
Comment 6 Jeremy Katz 2001-09-10 17:50:22 EDT
Fixed in Roswell, the beta for the next release of Red Hat Linux

Note You need to log in before you can comment on or make changes to this bug.