Bug 32639 - 6.2->7.1 upgrade: unresolved dependency --> no sugg.
6.2->7.1 upgrade: unresolved dependency --> no sugg.
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 2001-03-21 22:39 EST by Ben Levenson
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-29 12:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2001-03-21 22:39:58 EST
build qa0321.2
TUI-CDROM upgrade
6.2 Everything --> 7.1
Unresolved dependency.
Afterstep-APPS --> no suggestion
Comment 1 Bernhard Rosenkraenzer 2001-03-22 08:20:51 EST
We're no longer shipping Afterstep-Apps (and the 6.x version is using obsolete 
libraries, of course).

I can't think of a real fix for this problem (should anaconda requiring 
ancient libraries if there's no update available?)...
Comment 2 Michael Fulbright 2001-03-22 10:39:45 EST
Matt any ideas?
Comment 3 Bernhard Rosenkraenzer 2001-03-22 10:45:01 EST
Just noticed the typo in my comment - s/requiring/remove packages requiring/g 
of course.
Comment 4 Matt Wilson 2001-03-22 11:01:44 EST
we shouldn't remove packages which have broken dependencies...  isn't there
something that obsoletes afterstep-apps?

anyway - the installer is doing the requested behavior now.
Comment 5 Bernhard Rosenkraenzer 2001-03-22 11:07:01 EST
Nothing obsoletes Afterstep-APPS - we removed the AfterStep window manager 
without replacement, so we can't obsolete Afterstep-APPS either.
Comment 6 Matt Wilson 2001-03-22 18:22:36 EST
This should be working properly in tomorrow's tree.
Comment 7 Ben Levenson 2001-03-28 14:27:52 EST
build qa0328.0
6.2 "Everything" -> 7.1 TUI-CDROM
Unresolved dep. is still present:
AfterStep-APPS --> no sugg.
The following message was displayed on vc3:
* depcheck: package AfterStep-APPS needs libwraster.so.1 (not provided)
Comment 8 Matt Wilson 2001-03-29 12:17:30 EST
the installer is doing the right thing.
Comment 9 Ben Levenson 2001-04-05 19:53:24 EDT

Note You need to log in before you can comment on or make changes to this bug.