Bug 326641 - bouml-3.0.2 is available
bouml-3.0.2 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bouml (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Package...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 13:15 EDT by FEver
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 3.0.2-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 22:45:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FEver 2007-10-10 13:15:34 EDT
bouml-3.0.2 is already available. Repo version is 2.31.3.
Please update the package.

If you have any questions or suggestions related to Fever,
feel free to write them in this bug or have a look at
http://fedoraproject.org/wiki/PackageMaintainers/FEver

Don't send any messages to fevapp at o2.pl please.
Comment 1 Debarshi Ray 2007-11-04 10:01:49 EST
* Sun Nov 04 2007 Debarshi Ray <rishi@fedoraproject.org> - 3.0.2-1
- Version bump to 3.0.2. Closes Red Hat Bugzilla bug #326641.
- Introduced PHP support.
- Backported bug-fix from 3.3.
Comment 2 Kevin Kofler 2007-11-04 15:58:45 EST
Any reason you aren't updating to 3.3, which has been released today, while you 
are at it? Or maybe you weren't aware of the release, but then why didn't you 
package 3.2.1 from October 24?
Comment 3 Debarshi Ray 2007-11-04 17:28:51 EST
I am aware of all the Bouml releases that took place between 2.32.1 and 3.3.
Just for the sake of it, here are the FEVer filed bugs regarding these releases:
+ https://bugzilla.redhat.com/show_bug.cgi?id=332921
+ https://bugzilla.redhat.com/show_bug.cgi?id=344561
+ https://bugzilla.redhat.com/show_bug.cgi?id=355401
+ https://bugzilla.redhat.com/show_bug.cgi?id=365841

BOUML sees very frequent releases, and although it is well-developed upstream,
not all the releases are "safe". eg., often they have bugs which cause BOUML to
crash. If you visit http://bouml.free.fr/download.html you will notice 2.32
mentioned as the final stable release of the 2.x series. Releases >= 2.32.1 were
withdrawn because of such disruptive bugs. Similarly the early releases of the
3.x series were also withdrawn from the site.

At that point in time, upstream considered 2.32.1 as the most stable and recent
version and was very unsure about the stability of the later ones. With the
Fedora 8 release date looming I did not want to rock the boat, I kept it at
2.32.1. However, as I already mentioned, 2.32.1 also had a major issue.

When I contacted upstream and congratulated him for 3.3 today, he advised me to
backport the patch fixing the 2.32.1 crasher from 3.3 to 3.0.2. He specifically
asked me not to build 3.3, since it was very new and untested. As you can see in
the %changelog 3.0.2 has the back-ported patch.

See http://bouml.free.fr/historic.html regarding the releases.
Comment 4 Fedora Update System 2007-11-06 11:02:44 EST
bouml-3.0.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bouml'
Comment 5 Fedora Update System 2007-11-09 18:57:36 EST
bouml-3.0.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bouml'
Comment 6 Kevin Kofler 2007-11-09 21:11:32 EST
(Re comment #3) Thanks for the explanation.
Comment 7 Fedora Update System 2007-11-14 22:45:15 EST
bouml-3.0.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-11-14 22:45:39 EST
bouml-3.0.2-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.