Bug 326811 - Jed looks washed out in gnome terminal
Jed looks washed out in gnome terminal
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: jed (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 15:16 EDT by LH
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 16:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (371.42 KB, image/png)
2007-10-10 15:16 EDT, LH
no flags Details
Gnome terminal vs rxvt (304.79 KB, image/png)
2007-10-10 15:55 EDT, LH
no flags Details
screenshot (189.67 KB, image/png)
2007-10-10 16:10 EDT, LH
no flags Details

  None (edit)
Description LH 2007-10-10 15:16:04 EDT
Description of problem:

Jed looks washed out in gnome terminal.
Comment 1 LH 2007-10-10 15:16:04 EDT
Created attachment 223281 [details]
screenshot
Comment 2 Bill Nottingham 2007-10-10 15:44:19 EDT
I'm not seeing this in a brief test. Can you post it in comparison with another
terminal app? What color palette are you using in the terminal?
Comment 3 LH 2007-10-10 15:55:17 EDT
Gnome terminal has white on black palette. I'll put a comparison soon.
Comment 4 LH 2007-10-10 15:56:00 EDT
Created attachment 223321 [details]
Gnome terminal vs rxvt
Comment 5 Bill Nottingham 2007-10-10 16:03:17 EDT
Do you have a comparison of other apps *in gnome terminal*?
Comment 6 LH 2007-10-10 16:10:30 EDT
Created attachment 223341 [details]
screenshot

Sorry. That hit my mind soon after I posted the comparison but here you have a
new one. Both are white-on-black and tango colors.
Comment 7 Bill Nottingham 2007-10-10 16:29:54 EDT
jed by default uses the color 'black', which is the color in slot 0. vim is
using the 'background' color of the terminal.

With the tango colors, those aren't the same.
Comment 8 LH 2007-10-10 16:38:09 EDT
Thanks. Maybe I should tell the jed developers to use background or something
because this really looks like ass.
Comment 9 Bill Nottingham 2007-10-10 21:16:51 EDT
In your .jedrc, add something like:

set_color("normal", "default", "default");                      % default fg/bg

That should fix it for this case - you may need to replace other instances of
white (for foreground) and black (for background) with 'default' as well.


Note You need to log in before you can comment on or make changes to this bug.