Bug 326911 - java-1.7.0-icedtea-plugin not installed by default
java-1.7.0-icedtea-plugin not installed by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Jeremy Katz
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-10 16:22 EDT by Thomas Fitzsimmons
Modified: 2014-01-21 17:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 14:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Fitzsimmons 2007-10-10 16:22:29 EDT
A default x86 installation of Fedora 8 Test 3 includes java-1.7.0-icedtea but
not java-1.7.0-icedtea-plugin.

java-1.7.0-icedtea-plugin should be installed by default.  Here is the relevant
comps group:

  <group>
    <id>java</id>
    <_name>Java</_name>
    <_description>Support for running programs written in the Java programming
language.</_description>
    <default>true</default>
    <uservisible>false</uservisible>
    <packagelist>
      <packagereq type="mandatory">java-1.5.0-gcj</packagereq>
      <packagereq type="default">java-1.7.0-icedtea</packagereq>
      <packagereq type="default">java-1.7.0-icedtea-plugin</packagereq>
      <packagereq type="mandatory">libgcj</packagereq>
    </packagelist>
  </group>
Comment 1 Bill Nottingham 2007-10-10 16:31:03 EDT
Why wouldn't it be in the browser section?
Comment 2 Thomas Fitzsimmons 2007-10-10 16:58:13 EDT
I thought the description of the Java group matched java-1.7.0-icedtea-plugin's
function, and that users used to downloading Sun's Java for a working plugin
would look in the Java group first for configuring Java plugin support.  Either
categorization is  fine by me, as long as java-1.7.0-icedtea-plugin actually
gets installed by default.  Any idea why that's not happening with the current
comps?
Comment 3 Bill Nottingham 2007-10-10 21:49:45 EDT
Is the java group being selected in the installs you're doing?
Comment 4 Thomas Fitzsimmons 2007-10-11 07:44:19 EDT
I assume so, since java-1.5.0-gcj and java-1.7.0-icedtea are installed.  Josh,
did you check the state of the Java group as reported by Anaconda during the
install?
Comment 5 Joshua Sumali 2007-10-11 08:51:53 EDT
I'm not sure where the state of the Java group would be reported... Is there a
log recorded, or is it just something that shows up during the install? 
Comment 6 Joshua Sumali 2007-10-11 14:25:11 EDT
The installs I did were just default installs, so I did not look into the Java
group.
Comment 7 Bill Nottingham 2007-10-11 17:07:32 EDT
I just did a test install of rawhide, and it showed up there.

Were you installing from a live image?
Comment 8 Joshua Sumali 2007-10-12 08:50:56 EDT
My install was from the dvd, so not a live image.
Comment 9 Bill Nottingham 2007-10-12 11:35:16 EDT
What version of the DVD?
Comment 10 Joshua Sumali 2007-10-12 11:48:02 EDT
Fedora 8 Test 3 i386 - 2.9G - 2007-10-04 and
Fedora 8 Test 3 x86_64 - 3.5G - 2007-10-04.

Both DVDs say Fedora 7.92
Comment 11 Bill Nottingham 2007-10-12 13:25:59 EDT
java-1.7.0-icedtea-plugin was not in the Fedora manifest for test2. Can we make
sure it's in there for final?
Comment 12 Thomas Fitzsimmons 2007-10-18 08:57:40 EDT
Ping?
Comment 13 Bill Nottingham 2007-10-18 11:04:02 EDT
Fixed in pungi hg; requires a rebuild.
Comment 14 Will Woods 2007-10-19 17:56:49 EDT
Changing status since we have a fix.. close after pungi gets rebuilt, I guess.
Comment 15 Will Woods 2007-10-22 14:01:02 EDT
Fixed with the manifest updates for F8 final (pungi-1.1.6-1.fc8)

Note You need to log in before you can comment on or make changes to this bug.