Bug 32706 - [PATCH] Fsck. You dahm well broke NVIDIA cards :(
Summary: [PATCH] Fsck. You dahm well broke NVIDIA cards :(
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: SVGATextMode   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Helge Deller
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-22 15:50 UTC by h0e
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 15:50:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description h0e 2001-03-22 15:50:34 UTC
You added a small but insufferable RIVATNT patch to SVGATextMode that was
meant to add support for TNT but instead broke all nvidia. That's an
interesting case for qa :)

it's got a line in it that looks like this

+  if ( (!pcr) || (pcr->_device != PCI_CHIP_RIVA128) || (pcr->_device !=
PCI_CHIP_RIVATNT) )

and it should look like this

+  if ( (!pcr) || ((pcr->_device != PCI_CHIP_RIVA128) && (pcr->_device !=
PCI_CHIP_RIVATNT)) )

loverly stuff. now things work right. and now I can get to bed. night

ur doing a great job with all ur stuff btw! keep it up :)

Comment 1 Helge Deller 2001-03-27 17:28:48 UTC
Thanks for the patch, but SVGATextMode will be dropped from the distro starting
after RedHat Linux 7.


Note You need to log in before you can comment on or make changes to this bug.