Bug 327101 - Don't touch my curly braces!
Summary: Don't touch my curly braces!
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-rpm-editor   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alphonse Van Assche
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-11 00:31 UTC by Matěj Cepl
Modified: 2018-04-11 19:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-14 10:26:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before (186.52 KB, image/png)
2007-10-12 09:53 UTC, Matěj Cepl
no flags Details
after (185.32 KB, image/png)
2007-10-12 09:53 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2007-10-11 00:31:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.6) Gecko/20070926 Epiphany/2.20 Firefox/2.0.0.6

Description of problem:
When writing

%{_lib

Eclipse suggests on Ctrl-<space> completion of %_libdir (note missing curly braces). Please, don't do that, the completion should be %{_libdir} (for example), because it apparently means something else than %_libdir.

Version-Release number of selected component (if applicable):
eclipse-rpm-editor-0.1.0-8.fc8

How reproducible:
Always


Steps to Reproduce:
1. write %{_lib
2. press Ctrl-SPACE

Actual Results:
%_libdir is suggested

Expected Results:
%{_libdir} should be suggested (note BOTH curly braces are suggested)

Additional info:

Comment 1 Alphonse Van Assche 2007-10-12 06:51:20 UTC
Hi Matej,

In this case the specfile editor suggest you %_libdir but when you press enter
the braces are added automatically. 

Do you prefer to type %_li Ctrl-Space and have the possibility to configure that
the braces are not added automatically? 

Comment 2 Matěj Cepl 2007-10-12 09:52:45 UTC
(In reply to comment #1)
> In this case the specfile editor suggest you %_libdir but when you press enter
> the braces are added automatically. 

I cannot confirm this. See the following two screenshots before and after
Ctrl-Space<Enter> -- I begin with %{_lib and ended with %libdir.

Comment 3 Matěj Cepl 2007-10-12 09:53:26 UTC
Created attachment 225321 [details]
before

Comment 4 Matěj Cepl 2007-10-12 09:53:50 UTC
Created attachment 225331 [details]
after

Comment 5 Alphonse Van Assche 2007-10-12 11:50:42 UTC
That's a bug, I will take a look on that this weekend.

Thanks for the feedback

Comment 6 Alphonse Van Assche 2007-10-14 10:26:39 UTC
Ok, I had accidentally add code that make the macro completion sucking.
Fixed in 0.1.0-10.



Note You need to log in before you can comment on or make changes to this bug.