Bug 327151 - scim-bridge-gtk.i386 not installed for multilib
scim-bridge-gtk.i386 not installed for multilib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-10 22:55 EDT by Akira TAGOH
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-14 21:34:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2007-10-10 22:55:00 EDT
Description of problem:
When I installed from rawhide tree on x86_64 box, scim-bridge-gtk.i386 wasn't
installed. right now scim's xinput script that is to configure IM at the startup
time is checking if both immodules are available. so this makes XIM enabled then
because scim-bridge-gtk.x86_64 only is available.

The only way of enabling scim-bridge instead of XIM is to get both
scim-bridge-gtk packages installed for multilib because there are no way of
having different IM settings for an arch on gtk2.
Comment 1 Jens Petersen 2007-10-10 23:19:37 EDT
Also confirmed that this is still happening on latest x86_64 rawhide.
Comment 2 Jeremy Katz 2007-10-11 16:21:46 EDT
This is the expected behavior.  You have a requires on scim-bridge-gtk.  The
x86_64 package satisfies that requires.  If you want both installed, you either
need a) the package listed in comps (but that has the other downsides that have
been gone through at length) or b) have things require the actual libraries
Comment 3 Jens Petersen 2007-10-11 20:24:39 EDT
Probably we can fix this with an appropriate requires in scim-lang-*.
Comment 4 Jens Petersen 2007-10-12 01:28:34 EDT
I built scim-1.4.7-6.fc8 for this.
Comment 5 Jens Petersen 2007-10-14 21:34:18 EDT
Confirmed fixed with latest rawhide for Japanese install.

Note You need to log in before you can comment on or make changes to this bug.