This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 327231 - parsing syntext, parms, limits
parsing syntext, parms, limits
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Petr Rockai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 00:40 EDT by Darwin H. Webb
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 13:38:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2007-10-11 00:40:11 EDT
Description of problem:
On a disk witll 11  partions (1-3 LVM, 4 extended, 5-11 LVM
pvcreate /dev/sdb[1-3] was successfull for all pv's 1-3
pvcreate /dev/sdb[5-11]
returns message that pv was created for /dev/sdb1
pvcreate /dev/sdb[5-9] was successful for all pv's 5 thru 9
pvcreate /dev/sdb[10-11]
returns message that pv was created for /dev/sdb1
pvcreate /dev/sdb10 was successfull
pvcreate /dev/sdb11 was successfull

vgchange -a y
This causes all vg's to be activated. It would be better to have a parm of all
rather than no parm. I have accidently activated all vg's more than once.

So after all vg's were activited (using same disk as pvcreate.)
vgchange -a n vg2 vg3 vg5 ... vg11
the command completed but the text in the message said the vg's were now active
(same as vgchange -a y) rather than not activite.

system-config-lvm gui
On disk above with 116 lv's on vg1 , vg2-vg11 not active, no lv's 
the gui took 5-7 minutes to read in the display list.
Nothing could be selectioned and the tool was hung. A foce close was all that
would work.
The TOP program showed /usr/bin/sysst ? running and using 97% cpu
Kill -s 9 pid.
Tried again with same results.

Version-Release number of selected component (if applicable):
lvm2-2.02.28-1.fc8
system-config-lvm-1.1.1-2.0.fc8

How reproducible:
Everything in this config.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
wrong syntext, hung tool

Expected results:
parsing the command, a safety "all" parm, correct text, a more limitless and
faster tool.

Additional info:
Comment 1 Petr Rockai 2007-11-10 05:58:26 EST
A few points:
1) Please, create separate bug reports for separate issues,
2) that -a y is not really a bug but a change request, but due to backwards 
compatibility reasons, rather unlikely to be changed,
3) I don't quite understand what you mean with:
> pvcreate /dev/sdb[5-11]
> returns message that pv was created for /dev/sdb1
- please attach lvmdump output for the system
- also please attach full output of the affected pvcreate, with -vvvv
I also do not understand this:
> So after all vg's were activited (using same disk as pvcreate.)
How did you manage to create multiple VGs over a single set of PVs? Could you 
also post full outputs of all the commands leading to that situation?
4) I would keep this bug for the pvcreate bug, please open a separate one for 
system-config-lvm.

Thanks.
Comment 2 Alasdair Kergon 2007-11-11 13:38:53 EST
> pvcreate /dev/sdb[5-11]
> returns message that pv was created for /dev/sdb1

Read the man page for your shell.
The range '5-1' is empty, leaving sdb[1] as you saw.
Similarly [10-11] is equivalent to [1011] i.e. [01].

If you'd like vgchange to *require* vgname arguments, we could make that a
configurable setting in lvm.conf (disabled by default to preserve compatibility).

Note You need to log in before you can comment on or make changes to this bug.