Bug 327371 - ATI proprietary serverr crashes immediately
Summary: ATI proprietary serverr crashes immediately
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL: http://net.camk.edu.pl/bugs/001/
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-11 09:01 UTC by Krzysio (Chris) Leszczynski
Modified: 2018-04-11 13:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 19:42:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Krzysio (Chris) Leszczynski 2007-10-11 09:01:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install fresh Fedora 7
2. install ati proprietary driver according to
http://www.dcs.kcl.ac.uk/pg/kiran/tutorials/f7ati/index.php
  
Actual results:
Crashes immediately with backtrace:
Backtrace:
0: X(xf86SigHandler+0x6d) [0x48b99d]
1: /lib64/libc.so.6 [0x3663e30630]
2: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxSave64BitBAR+0x2d)
[0x2aaaab29a80d]
3: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxProbeMain+0x37f)
[0x2aaaab2a59bf]
4: X(InitOutput+0x6e7) [0x463707]
5: X(main+0x275) [0x434625]
6: /lib64/libc.so.6(__libc_start_main+0xf4) [0x3663e1dab4]
7: X(FontFileCompleteXLFD+0x229) [0x433ad9]



Additional info:
Logs, lists of installed rpms and hwconf is located at
http://net.camk.edu.pl/bugs/001/

I have already reported this bug to ATI/AMD site bug-reporting system. I'm
putting it here to because I'm not sure whether the real bug is in driver of
system libraries. Now both Redhat and ATI know about the problem

Comment 1 Matěj Cepl 2007-10-11 19:42:50 UTC
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).


Note You need to log in before you can comment on or make changes to this bug.