Bug 327401 - yum-cron output
Summary: yum-cron output
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-cron   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Habig, Alec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-11 09:37 UTC by Vadym Chepkov
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 0.6-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 07:14:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vadym Chepkov 2007-10-11 09:37:40 UTC
Description of problem:

yum-cron produces unexpected output if CHECK_ONLY=yes

Version-Release number of selected component (if applicable):
yum-cron-0.5-1.fc7

How reproducible:
set CHECK_ONLY=yes in /etc/sysconfig/yum-cron, run /etc/cron.daily/yum.cron

You will see '^M' sequence on the screen if any updates are present because of 
echo "`/usr/bin/yum -e 0 -d 0 -y -C check-update`^M" 

Additional info:
touch $LOCKFILE is not an atomic operation, so it won't serve the purpose of
preventing two instances running if two processes will start exactly at the same
time. The proper solution would be mkdir $LOCKFILE 2>/dev/null || exit , well,
you got the idea.

Comment 1 Habig, Alec 2007-10-12 20:47:15 UTC
Thanks for catching this bit of cut-n-paste disease, I should be using escape
characters rather than embedded ctrl sequences anyway.  Fixing...


Comment 2 Fedora Update System 2007-10-18 02:29:58 UTC
yum-cron-0.6-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-cron'

Comment 3 Fedora Update System 2007-10-24 07:14:19 UTC
yum-cron-0.6-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.