Bug 327451 - sshd segfaults when thinkfinger is configured
sshd segfaults when thinkfinger is configured
Status: CLOSED DUPLICATE of bug 324181
Product: Fedora
Classification: Fedora
Component: thinkfinger (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 06:02 EDT by Moritz Baumann
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 08:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of sshd -d -d -d -D -e (plus a cut and paste of the stacktrace) (18.99 KB, text/plain)
2007-10-11 06:02 EDT, Moritz Baumann
no flags Details

  None (edit)
Description Moritz Baumann 2007-10-11 06:02:56 EDT
Description of problem:

sshd segfaults on login using authentication method password


Version-Release number of selected component (if applicable):


How reproducible:

always (the segfault, sometimes ca. 1 times out of 3 the trace below).

Steps to Reproduce:
1. on the fedora7 machine do as root:
/etc/init.d/sshd stop
/usr/sbin/sshd -d -d -d -e
2. on remove machine do ssh <fedora 7 machine>
3. enter password
  
Actual results:

Connection closed by <ip of fedora 7 system>

Expected results:

login prompt.

Additional info:
if the line

auth sufficient pam_think_finger.so

is commented in /etc/pam.d/system-auth, it works as expected (but the
fingerprint reader cannot be user any more).

Before I upgraded today I saw a stacktrace which only happens occasionally.

just do the steps above a couple of times to see this happen.

Fedora 7 machine is Lenovo Thinkpad T 60 (Model 2007-CTO)
Comment 1 Moritz Baumann 2007-10-11 06:02:56 EDT
Created attachment 224201 [details]
output of sshd -d -d -d -D -e (plus a cut and paste of the stacktrace)
Comment 2 Moritz Baumann 2007-10-11 06:50:42 EDT
ssh <fedora 7 machine> using ssh-keys works fine.


And sorry for all the typos above (somehow I got no sleep last night).
Comment 3 Julian Sikorski 2007-10-11 08:42:42 EDT

*** This bug has been marked as a duplicate of 324181 ***
Comment 4 Julian Sikorski 2007-10-11 08:55:16 EDT
i386 packages for testing are under way

Note You need to log in before you can comment on or make changes to this bug.