Bug 32747 - Hidden epoch are annoying
Hidden epoch are annoying
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-22 17:51 EST by Olivier Crête
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 18:22:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 2001-03-22 17:51:43 EST
I've been running into lots of problem due to epoch recently. As most
packagers do not use epoch. But you (RedHat) and Ximian have decided to
include epoch in your recent packages, lots of packages do not upgrade
properly. Like when I installed Nautilus and the associated packages,
up2date and red-carpet are trying to downgrade them. It would be extremely
nice to have a system-wide option to ignore epoch. Or at least epoch to be
displayed without doing the --queryformat thing. 

My other main question is, why is this thing still in there? Is there ANY
package that uses epoch for good reasons?

Another idea would be to ignore the epoch if one of the packages does not
have one instead of making it equal 0.

While I'm at it, packages that include an epoch where the developer did not
intend it to include the epoch are positively broken... (that includes lots
of RH7 packages)...
Comment 1 Jeff Johnson 2001-03-22 17:56:08 EST
Yes, epoch's are annoying but absolutely necessary.
Comment 2 Olivier Crête 2001-03-22 18:15:13 EST
Could they be at least displayed in rpm -qi ?
And I'm still searching for an example where they where useful...?
Comment 3 Olivier Crête 2001-03-22 18:22:10 EST
From my understanding they are the same as serials?
If I want my package to be more recent that a redHat package... what should I
had to my spec file...

Serial: 1
Epoch: 1 

something else?
Comment 4 Jeff Johnson 2001-03-22 18:26:12 EST
Yes, epoch's are the modern name for Serial:

An important example is in perl-5.6 which, since 6 < 503, is not "newer" than
perl-5.00503.

Displaying epoch's uniformly throughout all of rpm, like -qi, is gonna take a
while to accomplish.

Meanwhile, you can use a --queryformat like
    rpm -q --qf '%{epoch}:%{name}-%{version}-%{release}\n' <pkg>
to display epoch's.

You can even extend rpm's command line options by doing
    echo "rpm alias --myquery -q --qf
'%{epoch}:%{name}-%{version}-%{release}\n'" >> /etc/popt

(Note: pardon the line wrap, the above is all one line)

to be used as
    rpm --myquery <pkg+>
if you wish to see the epoch's by default.

Note You need to log in before you can comment on or make changes to this bug.