Bug 327471 - XFS on ia64 architecture should be available without bootswitches
XFS on ia64 architecture should be available without bootswitches
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 06:12 EDT by Oliver Falk
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 07:49:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-10-11 06:12:35 EDT
Just a change request, not a bug. I think, that XFS filesystem should be
available per default on ia64 architecture, without adding boot-switches. Yes,
XFS is not officially supported by RH, but that's bad for SGI. :-(

Any reason why not to do this?
Comment 1 Jeremy Katz 2007-10-11 07:49:59 EDT
The RHEL5 kernel doesn't even include the xfs kernel module.  Also, even if it
were, it's not supported and exposing things of that nature in the installer
which aren't supported isn't desirable. 
Comment 2 Oliver Falk 2007-10-11 07:56:24 EDT
Jeremy, you knew, that this question will come: Why isn't it supported? Is XFS
something that isn't in upstream kernel or what?
Comment 3 Jeremy Katz 2007-10-11 10:02:49 EDT
As has been stated on many, many occasions, the decision to support something in
Red Hat Enterprise Linux is based on a variety of factors including being able
to fix problems encountered by customers.  Filesystems are pretty expensive in
this respect and so we limit what we support. 

If you want to campaign for more being supported, bugzilla is not the place for
it.  Instead, you should work it through support and/or your sales representative.
Comment 4 Oliver Falk 2007-10-15 04:05:57 EDT
Jeremy, I totally agree. It's not the best place to discus that, but I wanted to
know if there are any *technical* reasons. Well so far, I don't see any; It's
politics... There are SGI engineer sitting at RH who could take care about XFS
and fixing problems.

However, I'll try to *campaign* as you call it, in other places as well :-)

Note You need to log in before you can comment on or make changes to this bug.