Bug 327631 - pulseaudio doesn't save settings or work with system sound configuration
pulseaudio doesn't save settings or work with system sound configuration
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 09:24 EDT by Harry Bock
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 10:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Bock 2007-10-11 09:24:04 EDT
Description of problem:
With multiple soundcards in my system (Audigy/snd_emu10k1 and Intel
ESB2/snd_intel8x0), pulseaudio does not play nice. I have configured Fedora
through system-config-soundcard and gnome-sound-properties to use my Audigy as
the default output device, and testing it in those utilities works fine. 
Whenever I try to play sound, however, everything comes out of the Intel chipset.

When I look at pulse's volume control, I see the streams that are playing, and
can move them to the correct sound card (which is way cool).  Under output
devices, the Intel ESB2 is set as the default stream handler (which is NOT
obvious! you have to right click each device to find out if it's the default),
which is not what the system is configured for.

By the way, if a program does not go through pulseaudio (e.g., amarok which uses
xine instead of gstreamer right now), it uses the correct sound card.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.15.svn20071001.fc8
alsa-plugins-pulseaudio-1.0.14-4.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Configure audio with system-config-soundcard and/or gnome-sound-properties
2. Reboot
3. Play something through alsa/gstreamer (totem, flashplugin, etc)
  
Actual results:
Sound is output to the wrong soundcard (Intel ESB2)

Expected results:
Sound is output to the system configured sound card (Audigy)

Additional info:
Comment 1 Lennart Poettering 2007-10-15 10:51:11 EDT
system-config-sound is obsolete now, since it doesn't really work well with
hotplug sound cards, and causes more problems then it solves in such setups. For
now, pavucontrol is the way to go for defining the default sound card. For F9 we
will probably integrate this better with gnome-sound-properties. 

Oh, and pavucontrol even includes a "hint" line at the bottom that tries to
inform you about the right click menu. I know this isn't perfect. But yepp,
that's another story. pavucontrol could need some love, that's for sure.

I am closing this bug now, since system-config-soundcard is obsolete for
configuring audio, it's fine for testing, but not for configuring. It has been
removed from firstboot as well. 

The correct way to identify sound devices these days is through stable HAL UDIs,
which is what PA does. Using ever-changing and conflicting indexes (like s-c-s
does) is problematic and thus no longer recommended.

Note You need to log in before you can comment on or make changes to this bug.