Bug 3281 - passwd operator doesn't work?
passwd operator doesn't work?
Status: CLOSED DUPLICATE of bug 5005
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-05 10:48 EDT by Karl Berry
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-09 09:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Berry 1999-06-05 10:48:33 EDT
Am I going crazy?  I installed Red Hat 6.0 (`Everything'),
all was well, I logged in as root on the console, typed
passwd operator to enable a non-root account, it said
  passwd: all authentication tokens updated successfully
but /etc/passwd didn't actually change, the password was
still *.  I tried several different passwords.

I did not enable MD5 passwords or NIS+ on the new setup
screen at the end.

This is not peculiar to operator.  For example, I just tried
passwd bin (another account with a * password), used
jac:jil! for the password, and /etc/passwd didn't change
despite the success message.
Comment 1 Jeff Johnson 1999-06-05 11:12:59 EDT
Change the password field from '*' to '!!' and you will be able to
change the password.
Comment 2 theman 1999-09-08 21:17:59 EDT
This is not reasonable. No other unix does anything this stupid. Root
using passwd to change the entry should ALWAYS work, no matter the
existing contents. WHAT THE HELL WERE YOU THINKING?
Comment 3 Jeff Johnson 1999-09-09 09:26:59 EDT
*** This bug has been marked as a duplicate of 5005 ***

Note You need to log in before you can comment on or make changes to this bug.