Bug 328121 - yum needs trailing slash on proxy port number
yum needs trailing slash on proxy port number
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 14:46 EDT by Michael Rice
Modified: 2014-01-21 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 11:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
non-working yum.conf (306 bytes, text/plain)
2007-10-12 15:35 EDT, Michael Rice
no flags Details

  None (edit)
Description Michael Rice 2007-10-11 14:46:51 EDT
Description of problem:
To get yum to use a proxy you must add a trailing slash to the port


Version-Release number of selected component (if applicable):
yum-3.2.5-1.fc7

How reproducible:
every time


Steps to Reproduce:
1.set proxy=http://some.proxy:3128 in yum.conf
2.
3.
  
Actual results:
[Errno 4] IOError: <urlopen error nonnumeric port: '3128?'>



Expected results:
it should work


Additional info:
to fix it add :3128/
Comment 1 Jeremy Katz 2007-10-11 16:35:27 EDT
It looks like there's a non-printable character that snuck in there.  Can you
attach your entire yum.conf in its non-working state? 
Comment 2 Michael Rice 2007-10-12 15:35:49 EDT
Created attachment 226041 [details]
non-working yum.conf
Comment 3 Michael Rice 2007-10-12 15:38:10 EDT
I used od -c on the file and \n is the only thing to follow :3128

0000260   m   :   3   1   2   8  \n

Comment 4 Dave Russell 2007-10-23 11:14:42 EDT
I had the same issue, but I think the "non numeric port" might be a red herring.

For me if I use the documented:
proxy=
proxy_user=
proxy_pass=

Then it breaks...

However if I use:

proxy=http://proxy_user:proxy_pass@proxy.url

Then it works!

Give that a try.
Comment 5 Seth Vidal 2008-03-12 10:54:47 EDT
YUMBUGDAY
Comment 6 James Antill 2008-03-13 11:16:32 EDT
 Ok, I see the problem ... fixed.

Note You need to log in before you can comment on or make changes to this bug.