Bug 32828 - wheelmouse scroll disabled
Summary: wheelmouse scroll disabled
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rxvt   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-23 16:36 UTC by Habig, Alec
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 14:05:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Habig, Alec 2001-03-23 16:36:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25smp i686)


in rxvt-2.7.5-12, the patch which fixes an autoconf logic reversal in the
wheelmouse support has been commented out of the specfile.

For some reason, if --enable-wheelmouse is selected in the configure, then
the NO_WHEEL_MOUSE define is defined - the opposite behavior from what
you'd want. 

Someone has already fixed this.  But, the fix is currently commented out. 
Uncommenting Patch7 in the specfile fixes this bug.


Reproducible: Always
Steps to Reproduce:
1. Try to use a wheelmouse!
2.
3.
	

Actual Results:  It doesn't scroll.

Expected Results:  The history should scroll.


My guess is that the dev branch of rxvt, 2.7.x, fixes this problem, and
that when you guys went to this branch temporarily, the patch for 2.6.x was
commented out since it wasn't needed anymore.

Comment 1 Harald Hoyer 2001-03-28 14:05:05 UTC
hmm ... don't know who commented out the patch, but as you can see in the history, this was already 
fixed. Reenabled the patch. Should work now.


Note You need to log in before you can comment on or make changes to this bug.