Bug 32836 - Lilo not set up correctly
Lilo not set up correctly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 12:47 EST by Chris Ricker
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 12:47:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-03-23 12:47:21 EST
This is with qa0322.

After the install, it just comes up with LI and hangs trying to execute the
secondary loader.

During the install, I selected automatic partitioning.  I also unselected
to install LILO to the mbr, and told it to install only to the partition
instead.  Partitioning created

/		hda5 (active)
/boot		hda1
swap		hda6

and anaconda created a lilo.conf file of

boot=/dev/hda1
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=linux

image=/boot/vmlinuz-2.4.2-0.1.32
	label=linux
	read-only
	root=/dev/hda5


which should all be fine.  It doesn't work, however.  I can get it to work
by switching to installing LILO to the MBR (boot=/dev/hda), installing
lilo, and then switching it back (boot=/dev/hda1) and re-installing lilo.

I shouldn't have to do all that to have lilo on the active partition
instead.  I suspect the problem is that the machine doesn't have an MBR
until I do the whole double-install of lilo.  Anaconda really should be
dropping a generic MBR on there....
Comment 1 Matt Wilson 2001-03-23 18:00:26 EST
that LI must be from an old copy of LILO you installed on the MBR.  We can't go
around replacing people's MBRs if they select to install LILO on a partition -
people may have a different boot manager installed on the MBR.
Comment 2 Chris Ricker 2001-03-23 18:59:39 EST
Oh, that makes sense.  I thought I'd zero'd the drive.

I'll do another install after zeroing to double-check, but definitely leave this
one resolved for now.

Note You need to log in before you can comment on or make changes to this bug.