Bug 3284 - Ping fails at odd bytes
Ping fails at odd bytes
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: netkit-base (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-05 12:28 EDT by egbert
Modified: 2015-01-07 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-05 16:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description egbert 1999-06-05 12:28:41 EDT
Using RedHat 6.0 distributed by LinuxCentral (courtesy of
North Texas Linux User Group), I am unable to perform the
following command.

ping localhost -s 301

There is no ICMP reply.   This is true for any interfaces
and most odd-byte size.

I'm running RedHat 6.0 (2.2.5-15) on i686 platform.
It was distributed by
LinuxCentral.  I am not able to PING with a size of
301 (or any odd-byte
size) to a localhost.  This occurred on several
i686 platforms with 6.0.

egcs version is 2.91.66.
ld version is 2.9.1
as version is 2.9.1

Have you duplicated this yet?  If so and corrected,
what course of action
should I take?


Steve
egbert@efficient.com


Alan Cox wrote:

> Someone shipped a broken ping binary (actually it
seems to be an egcs bug)
Comment 1 egbert 1999-06-05 12:30:59 EDT
I've recompiled the ping binary, "libc", and the kernel as suggested
by Alan Cox to no avail using the same EGCS 2.9....
Comment 2 Jeff Johnson 1999-06-05 13:24:59 EDT
This problem has been corrected in netkit-base-0.10-31.*.rpm
available from ftp://rawhide.redhat.com/alpha/RedHat/RPMS/. Please
obtain and install newer rpm to see if this fixes the problem for you.
Comment 3 egbert 1999-06-05 15:49:59 EDT
Suggested RPM file is not found.
ftp://rawhide.redhat.com/alpha/RedHat/RPMS/.
Comment 4 egbert 1999-06-05 15:51:59 EDT
Since RedHat fix is not available, I went ahead and tried OpenLinux's
netkit-base-0.11+ to no avail obtained from Caldera's site.

Same result.
Comment 5 egbert 1999-06-05 15:59:59 EDT
Suggested RPM file is not found.
ftp://rawhide.redhat.com/alpha/RedHat/RPMS/.
Comment 6 egbert 1999-06-05 16:01:59 EDT
The range of ping size failure are:

11-1471 (all odd numbers)

This ONLY occurs during outgoing ICMP-REQUESTs from RedHat 6.0, 6.0
does generate correct ICMP-REPLies to seemingly any hosts (except
localhost).
Comment 7 egbert 1999-06-05 16:02:59 EDT
The range of ping size failure are:

11-1471 (all odd numbers)

This ONLY occurs during outgoing ICMP-REQUESTs from RedHat 6.0, 6.0
does generate correct ICMP-REPLies to seemingly any hosts (except
localhost).
Comment 8 Jeff Johnson 1999-06-05 16:11:59 EDT
Wait a bit, Raw Hide will be back. Change the alpha in the URL if
you want a different arch. Send me mail if you can't wait ...

Note You need to log in before you can comment on or make changes to this bug.