Bug 328601 - Installation fails with multiple EIDE drives
Installation fails with multiple EIDE drives
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 17:48 EDT by David Dotson
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt generated when the partion step fails. (31.31 KB, text/plain)
2007-10-11 17:48 EDT, David Dotson
no flags Details

  None (edit)
Description David Dotson 2007-10-11 17:48:07 EDT
Ubuntu installation works fine, but Fedora can't seem to partition multiple
drives in a logical volume, the partioning step fails. Attached is the
anacdump.txt file generated.
Comment 1 David Dotson 2007-10-11 17:48:08 EDT
Created attachment 224831 [details]
anacdump.txt generated when the partion step fails.
Comment 2 Jeremy Katz 2007-10-11 19:20:56 EDT
What did you previously have installed?  Are there any kernel errors on tty4?
Comment 3 David Dotson 2007-10-11 20:39:46 EDT
I had Fedora 6 installed before on a 40gig drive, and I added a new 160gig drive
to the system to compliment the 40g drive. It doesn't seem to matter if I only
use a single drive (40g or 160g) the same error results. No noticable error
messages show up. The installation freezes in either text or GUI mode. Would
error messages be written to a log somehow if the partition can't be removed? I
guess I'm not sure how I could trap these errors other than supply the
anacdump.txt file.

I am guessing that the installation is trying to remove the existing volume
group from the drive(s), and it fails for some reason. I used a disk utility to
write zeros to the drives so that Fedora will only try to create the LVM, but
that didn't work either. I'm going to try it again in text mode with the
installation DVD and see if its an identical error. I wouldn't think that would
be the case because there shouldn't be a LVM to remove in that instance.

In this case, I'm using the KDE Live CD. I've tried using the DVD installation
in the past with similar results (freezes) but I don't get the chance to save
the anacdump to a floppy, so I can't tell you if its the exact same error. 

Another thing I'm going to try to is reinstall the ubuntu distribution I had
installed. That seemed to work originally, but I really wanted to use fedora 7.
Maybe if ubuntu can be installed correctly, I can install fedora over the top
and it won't have a problem removing the volume. 

thanks for your time.
Comment 4 Bug Zapper 2008-05-14 10:43:17 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Andy Lindeberg 2008-06-03 17:30:22 EDT
Have you encountered the same problem when upgrading to Fedora 9?
Comment 6 Bug Zapper 2008-06-16 22:38:54 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.