Bug 328661 - hdf5 fails to build due to not finding compilers
hdf5 fails to build due to not finding compilers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hdf5 (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 18:47 EDT by Doug Chapman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 13:00:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-10-11 18:47:34 EDT
Description of problem:
When trying to build hdf5 under Fedora 8 on ia64 (however I imagine all arches
will hit this) it fails in the configure stage due to not finding the c, c++ and
gfortran compilers.

Adding exports for the appropriate varables in the spec file fixes this:

%build
export CC=gcc
export F9X=gfortran
export CXX=g++
%configure --with-ssl --enable-cxx --enable-fortran \
           --enable-threadsafe --with-pthread
make


Version-Release number of selected component (if applicable):
hdf5-1.6.5-9.fc8.src.rpm


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Orion Poplawski 2007-10-17 13:00:50 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.