Bug 328721 - weird X lock-up after login on 9600XT
Summary: weird X lock-up after login on 9600XT
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-11 23:35 UTC by cje
Modified: 2018-04-11 06:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 22:28:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description cje 2007-10-11 23:35:19 UTC
Description of problem:
a while (few minutes) after logging in X seems to gradually lock up the system.
 first the mouse stops moving.  a few minutes later the system becomes entirely
unresponsive and never (left it for several hours) recovers.  if i ctrl-alt-bksp
when the mouse stops moving then the system survives.

Version-Release number of selected component (if applicable):
something-something-195.2 i think.  pretty sure ...194 made gdm die and ...195
fixed that but caused this.

How reproducible:
always.  but it doesn't go wrong if i leave the system at the gdm screen.  also
it's possible it doesn't go wrong if i use a default gnome desktop.

good luck!  let me know what more info i should provide and what i can try
changing.  for example, should i try vesa, fglrx and the F7 ati drivers for
comparison?  is it worth messing with bios settings and disabling composite,
aiglx and dri?

Comment 1 Dave Airlie 2007-10-11 23:43:35 UTC
are you using desktop effects? running compiz?

if yes, please disable them.

if no, try disabling DRI and see what happens..

Comment 3 cje 2007-10-12 18:29:19 UTC
i'd already switched desktop effects off.

i've just done a yum update and reboot and now we're back to gdm
crashing/restarting X.  the update doesn't appear to contain any changes to this
component or gdm.  the most significant updates i can see are libX11, libgnome,
udev and glibc.

so, anyway, i'd like to try disabling DRI.  hmmmmm.  is there a Right way of
doing that?  i'm not using an xorg.conf file and the old one i used to use
(created by s-c-d) doesn't have a 'Modules' section in it.  do i just make one
with an empty Modules section?

in case it's relevant: i've got two monitors connected to the card, both vga,
one in a dvi-vga converter.  it's defaulting to clone mode - i couldn't get
dual-head working.

Comment 4 cje 2007-10-12 18:30:50 UTC
ah.  it's okay - i just found the default xorg.conf in the Xorg.0.log file. 
i'll copy it and comment out DRI.  brb.

Comment 5 cje 2007-10-12 18:55:50 UTC
right, done that.  gdm still appears to be killing X.

xinit works okay.  from that xterm, twm works but metacity dies immediately with
"Illegal instruction" (well, i think that's what it says - i've got the system
stuck in French for the time being!)

Comment 6 cje 2007-10-12 19:10:19 UTC
BTW, thanks for the quick response yesterday - sorry i didn't spot it until
today.  i'll stick around this time if you want to try a few things quickly.  :-)

Comment 7 cje 2007-10-12 23:35:50 UTC
okay, gdm problem is something else - just changed to vesa driver and it's still
restarting X when gdm runs.

i think i'll do a clean f8t3 dvd install and see how it is after that.

Comment 8 Matěj Cepl 2007-10-15 14:43:41 UTC
Cool, please, let us know, how Xorg went after reinstall.

Comment 9 cje 2007-10-19 20:54:39 UTC
it's all looking pretty good.  tried lots of 3D stuff and it's not gone wrong yet.

:-)

Comment 10 cje 2007-10-19 22:28:35 UTC
aha!  broke it again, fixed it.

enabling laptop-mode from http://samwel.tk/laptop_mode/packages/fedora caused
the "gdm screen restarts X" problem - even if using the vesa driver.

however, it's something specific to this platform as i have laptop-mode enabled
elsewhere without this problem.  i'll keep looking into it and raise it
elsewhere if i can pin it down a bit.

thanks again.


Note You need to log in before you can comment on or make changes to this bug.