Bug 328851 - games-sound creates gstreamer warnings
games-sound creates gstreamer warnings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 21:59 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.10.14-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 12:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-11 21:59:44 EDT
Description of problem:

If you enable sound in any of gnome-games, you get warnings such as:

(iagno:5546): GStreamer-CRITICAL **: gst_event_new_new_segment_full: assertion
`start <= stop' failed

(sol:4720): GStreamer-CRITICAL **: gst_event_new_new_segment_full: assertion
`start <= stop' failed

every time a sound is played. 

Version-Release number of selected component (if applicable):

gnome-games-2.20.0.1-2.fc8
Comment 1 Matthias Clasen 2007-10-11 23:26:42 EDT
Here is a stacktrace


#0  0x00764a76 in IA__g_logv (log_domain=0x3bc3574 "GStreamer", 
    log_level=G_LOG_LEVEL_CRITICAL, 
    format=0x7b0007 "%s: assertion `%s' failed", 
    args1=0xb6efef0c "d\226�\003�\220�\003p8\022") at gmessages.c:395
#1  0x00764f89 in IA__g_log (log_domain=0x3bc3574 "GStreamer", 
    log_level=G_LOG_LEVEL_CRITICAL, 
    format=0x7b0007 "%s: assertion `%s' failed") at gmessages.c:517
#2  0x0076506b in IA__g_return_if_fail_warning (
    log_domain=0x3bc3574 "GStreamer", 
    pretty_function=0x3bc9664 "gst_event_new_new_segment_full", 
    expression=0x3bc90ce "start <= stop") at gmessages.c:532
#3  0x03b787b5 in gst_event_new_new_segment_full (update=0, rate=1, 
    applied_rate=1, format=GST_FORMAT_TIME, start=9223372036854775807, 
    stop=162630385, position=0) at gstevent.c:520
#4  0x03b78955 in gst_event_new_new_segment (update=0, rate=1, 
    format=GST_FORMAT_TIME, start=9223372032622474612, stop=62666100, 
    position=62666100) at gstevent.c:442
#5  0x00e48051 in gst_ogg_demux_handle_page (ogg=0x8b4e558, page=0xb6eff16c)
    at gstoggdemux.c:2747
#6  0x00e48a05 in gst_ogg_demux_chain (pad=0x8e0ac18, buffer=0xb6f01db0)
    at gstoggdemux.c:2847
#7  0x00e491c8 in gst_ogg_demux_loop (pad=0x8e0ac18) at gstoggdemux.c:2934
#8  0x03ba2f76 in gst_task_func (task=0x8d83290, tclass=0x8e24958)


The start value there is G_MAXINT64, as set here:

static gboolean
gst_ogg_demux_collect_chain_info (GstOggDemux * ogg, GstOggChain * chain)
{
  gint i;
  gboolean res = TRUE;

  chain->total_time = GST_CLOCK_TIME_NONE;
  chain->segment_start = G_MAXINT64;


Comment 2 Andreas Røsdal 2007-10-14 17:09:31 EDT
This is a bug in GStreamer, already reported some time ago. It's already fixed
in SVN, now we need a new release of GStreamer:

http://bugzilla.gnome.org/show_bug.cgi?id=466717
Comment 3 Hans de Goede 2007-10-15 03:28:23 EDT
Thanks for the pointer, changing component and asignment to gstreamer-plugins-base.

Note to the gstreamer-plugins-base maintainer, this is fixed by the following 2
commits from upstream:
http://webcvs.freedesktop.org/gstreamer/gst-plugins-base/ext/ogg/gstoggdemux.c?r1=1.180&r2=1.181&view=patch
http://webcvs.freedesktop.org/gstreamer/gst-plugins-base/ext/vorbis/vorbisdec.c?r1=1.127&r2=1.128&view=patch
Comment 4 Bastien Nocera 2007-10-18 11:18:17 EDT
Should be fixed in gstreamer-plugins-base-0.10.14-6.fc8

Let me know if it fixes the bugs for you, and I'll get it tagged for F8 final.

Packages would be at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=201962
Comment 5 Bill Nottingham 2007-10-18 11:28:19 EDT
Works for me.
Comment 6 Bastien Nocera 2007-10-18 12:44:39 EDT
Built and tagging e-mail sent.

Note You need to log in before you can comment on or make changes to this bug.