Bug 328861 - installation kernel fails to boot w/ > 2 GB RAM onboard ....
installation kernel fails to boot w/ > 2 GB RAM onboard ....
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 22:14 EDT by William A. Mahaffey III
Modified: 2008-02-15 21:47 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23*
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from 3 commands .... (150.75 KB, text/plain)
2008-01-14 23:19 EST, William A. Mahaffey III
no flags Details

  None (edit)
Description William A. Mahaffey III 2007-10-11 22:14:21 EDT
Description of problem:installer-kernel fails during install w/ > 2 GB RAM
installed in system. message ends with 'aiieeeeee killing interrupt handler'


Version-Release number of selected component (if applicable):


How reproducible: get hold of x86_64 system, install 4 GB RAM, kick off
installer, fails like clockwork for me ....


Steps to Reproduce:
1. access x86_64 box w/ 4 GB RAM onboard
2. kick okk installation DVD
3. it dies w/ colorful message 100% for me ....
  
Actual results:


Expected results:


Additional info: nothing to attach, fails before I can recover anything ....
Comment 1 William A. Mahaffey III 2007-10-12 12:56:12 EDT
Should have mentioned earlier, this happens w/ the Fedora 7 installer, not
fc6test3 as was my best/only option in the menu when I filed this, sorry ....

mbd in this case was/is Gigabyte P965 DS3, newly purchased, w/ Q6600 CPU & 8 GB
of RAM (4X2GB sticks) max. It ran memtest86 for ~22 hours w/ all 8 GB installed,
7 passes, 0 errors.
Comment 2 Pete Zaitcev 2007-10-26 00:34:24 EDT
This seems like an isolated report, unless Chuck saw something...
Could you take a picture of the screen (after vga=ask and selecting
smaller letters)? As it is, there's no telling what is happening.
Comment 3 William A. Mahaffey III 2007-10-26 08:43:15 EDT
Not without going back & duplicating the install on what is now an up-&-running
server-ish box :-). I have had this problem *VERY* consistently over the years,
w/ SuSE 8.2/9.2 years back, then FC5 on a 933 MHz box that I still have. I
always have to remove RAM to get down to some smallish amount for the
installation kernel to boot correctly. I also filed, then withdrew a bug about
the installed kernel doing the same thing, which it has done for me on 2
different boxen, 1 Intel Q6600 based (a few weeks ago, same time frame as this
bug) & 1 Intel E6600 box (yesterday). That was solved (in both cases) by a
kernel upgrade (yum -y upgrade kernel) immediately after installation in both
cases (bug 328871, filed & withdrawn).
Comment 4 Chuck Ebbert 2007-10-26 14:57:08 EDT
Fedora 7 respins (up-to-date installation DVD/CD sets) are at:

http://spins.fedoraunity.org/spins

Comment 5 Christopher Brown 2008-01-14 13:38:20 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 6 William A. Mahaffey III 2008-01-14 15:21:21 EST
Yes definitely still happens, has been happening in 1 form or another for me for
years (under Mandrake, SuSE, & now RedHat). I think it is something generic to
Linux, not particular to RH, but still irritating. It also complicates
converting to Linux. I haven't done any mew installs in a few months which is
why I haven't commented further, but, yes, it happened the last time I tried
(FC7 install from DVD onto Intel Q6600 box w/ 8 GB RAM). In years past the limit
was 1 GB of RAM, and lower than that farther back, but it has always been
(irritatingly) present. It is a hassle to have to open up & partially strip the
box to install Linux :-( ....
Comment 7 Christopher Brown 2008-01-14 15:47:54 EST
Could you attach output from the following commands as separate text/plain
attachments to this bug:

# dmidecode
lspci -vvxxx
dmesg

Cheers
Chris
Comment 8 William A. Mahaffey III 2008-01-14 23:19:09 EST
Created attachment 291674 [details]
output from 3 commands ....

OK, here you are. let me know if you need more ....
Comment 9 Christopher Brown 2008-01-14 23:57:47 EST
There is a BIOS upgrade for your motherboard available which you may wish to
consider, though it does not specifically indicate this will resolve the issue.

Your BIOS indicates 4 GB is the maximum, not 8 GB. Please try booting/installing
with:

acpi=off

as described here:

http://fedoraproject.org/wiki/KernelCommonProblems
Comment 10 William A. Mahaffey III 2008-01-15 08:09:07 EST
Hmmmmm .... the box runs AOK (after kernel upgrade) w/ 8 GB onboard, & ran
memtest86+ for 20-ish hours w/ all 8 GB before installation. I'll look into the
BIOS upgrade, though I am having no indications of problems at the moment. My
manual (& NewEgg) said 8 GB max when I bought the board, that was 1 of the
criteria (> 4 GB RAM capable) when I was shopping ....
Comment 11 Christopher Brown 2008-01-15 20:12:51 EST
Differences between box and their contents are not unknown to me either I'm
afraid. Anyway from dmidecode:

Handle 0x001B, DMI type 16, 15 bytes.
Physical Memory Array
	Location: System Board Or Motherboard
	Use: System Memory
	Error Correction Type: None
	Maximum Capacity: 4 GB
	Error Information Handle: Not Provided
	Number Of Devices: 4

Good to know its running better - setting back to NEEDINFO - please close when
you're happy or update if it recurs.
Comment 12 Chuck Ebbert 2008-01-16 16:25:47 EST
This problem should be solvable by adding "mem=2000M" to the boot options during
install...

Note You need to log in before you can comment on or make changes to this bug.