Bug 328911 - Evolution crash on KDE when press ENTER with empty "TO:" field
Evolution crash on KDE when press ENTER with empty "TO:" field
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 23:58 EDT by Leonardo Scandura Neto
Modified: 2007-12-27 13:56 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-2.12.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 13:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stacktrace (3.95 KB, text/plain)
2007-10-15 09:06 EDT, Leonardo Scandura Neto
no flags Details

  None (edit)
Description Leonardo Scandura Neto 2007-10-11 23:58:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.7 (like Gecko)

Description of problem:
I run evolution-2.10.3-4-fc7 on kdebase-3.5.7-13.1.fc7 with f7.
In "Compose Message" window, if I press ENTER button with empty (no address) 
field "To:", evolution crash.

Version-Release number of selected component (if applicable):
evolution-2.10.3-4.fc7

How reproducible:
Always


Steps to Reproduce:
1. Install live-image one-cd f7 with kde, update system, install evolution.
2. Configure Evolution. On main window click on NEW.
3. On Compose Message window, with empty field "To:", click on field and hit 
ENTER.

Actual Results:
Evolution crash.

Expected Results:
Nothing. Evolution keep running.

Additional info:
Comment 1 John (J5) Palmieri 2007-10-12 11:35:11 EDT
Why is this assigned to a fonts package?  BTW Evolution doesn't touch KDE
libraries.  I can confirm this happens with an up to date F7 in the GNOME DE
also.  Reassigning.
Comment 2 Matthew Barnes 2007-10-12 19:57:29 EDT
I can't reproduce this with Evolution 2.12.0 on GNOME.

Could you possibly attach a stacktrace with debuginfo so that I can confirm
whether it's been fixed since 2.10?  (/me bets it's another NULL pointer to
strcmp() bug.)
Comment 3 Leonardo Scandura Neto 2007-10-15 09:06:28 EDT
Created attachment 227611 [details]
Stacktrace
Comment 4 Matthew Barnes 2007-10-15 11:08:18 EDT
Thanks for the stacktrace but it's missing debuginfo.

Can you please install the following packages and post another stacktrace:

   evolution-data-server-debuginfo
   gtk2-debuginfo
   glib2-debuginfo
Comment 5 Leonardo Scandura Neto 2007-12-27 13:56:08 EST
Sorry, i have no more that installation.
In F8 with evolution-2.12.2-2.fc8 this bug already been corrected.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.