Bug 328931 - anaconda writes IPV6ADDR=dhcp in ifcfg-eth<whatever>
anaconda writes IPV6ADDR=dhcp in ifcfg-eth<whatever>
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 328921 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-12 00:00 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 17:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-12 00:00:29 EDT
Description of problem:

That's not valid. What are you intending by such a configuration?

Version-Release number of selected component (if applicable):

anaconda-11.3.0.38-1
Comment 1 Bill Nottingham 2007-10-12 00:01:39 EDT
Poking at the anaconda source, I see:

loader.c:648:        loaderData->ipv6 = strdup("dhcp");
loader.c:1272:                        loaderData->ipv6 = strdup("dhcpv6");

Presumably that's the source, although one of those lines probably needs fixed.
Comment 2 Bill Nottingham 2007-10-12 00:38:55 EDT
*** Bug 328921 has been marked as a duplicate of this bug. ***
Comment 3 David Cantrell 2007-10-23 17:05:19 EDT
The internal Network object in anaconda does not directly map down to ifcfg-*
settings.  At one point it did, so I added support to write out correct IPV6
values based on what we collected from the user.

Note You need to log in before you can comment on or make changes to this bug.