This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 32898 - i2o fails to mount root fs on boot after installation of qa0322
i2o fails to mount root fs on boot after installation of qa0322
Status: CLOSED DUPLICATE of bug 32834
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 16:26 EST by Stephen Elia
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 16:26:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Elia 2001-03-23 16:26:23 EST
Update from Matt Wilson:
There are 2 problems at fault here:

1)  mkinitrd loads i2o_core and i2o_pci, but not i2o_block.  I have
    fixed this.  The fix is not yet included in any tree released.

2)  even if i2o_block were loaded, it is not correctly reading the
    partition table at initialization.  Alan will be arriving shortly
    and has offered to look at this problem on the hardware that
    exhibits the failure.


Reproducible: Always
Steps to Reproduce:
1. Install to Intel i2o device
2. Reboot
3. Boot default install kernel (Linux)
	

Actual Results:  While booting the i2o failed to mount root fs, with the 
following message (For clarity I included the entire i2o initalization at 
boot):

loading i2o_pci module
Linux I2O PCI Support (c) 1999 Red Hat Software.
Loading i2o_core module
I2O Core - (C) Copyright 1999 Red Hat Software
i2o: Checking for PCI I2O controllers...
i2o: I2O Controller on bus 1 at 41.
i2o: PCI I2O Controller at 0xFC000000 size=33554432
I2O: MTRR workaround for Intel i960 processor
i2o/iop0: Installed at IRQ44
i2o: 1 I2O controller found and installed.
I2O: Event thread created as pid 15
Activating I2O controllers...
This may take a few minutes if there are many devices
i2o/iop0: LCT has 12 entries.
VFS: Cannot open root device "5006" or 50:06
Please append a correct "root=" boot option
Kernel Panic: VFS: Unable to mount root fs on 50:06

After adding "root=/dev/i2o/hda6" to command line the following message 
appeared at boot (For clarity I included the entire i2o initalization at 
boot):

loading i2o_pci module
Linux I2O PCI Support (c) 1999 Red Hat Software.
Loading i2o_core module
I2O Core - (C) Copyright 1999 Red Hat Software
i2o: Checking for PCI I2O controllers...
i2o: I2O Controller on bus 1 at 41.
i2o: PCI I2O Controller at 0xFC000000 size=33554432
I2O: MTRR workaround for Intel i960 processor
i2o/iop0: Installed at IRQ44
i2o: 1 I2O controller found and installed.
I2O: Event thread created as pid 15
Activating I2O controllers...
This may take a few minutes if there are many devices
i2o/iop0: LCT has 12 entries.
Kernel panic: I have no root and I want to scream


Expected Results:  i2o should have completed initalization, mounted root 
and continued booting.
Comment 1 Matt Wilson 2001-03-23 16:31:23 EST
#1 is fixed in our current tree, #2 is a dup of 32834


*** This bug has been marked as a duplicate of 32834 ***

Note You need to log in before you can comment on or make changes to this bug.