Bug 329161 - No hardware support for integrated modem on Dell Inspiron 1520 (Conexant HDA D330 MDC v.92)
No hardware support for integrated modem on Dell Inspiron 1520 (Conexant HDA ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://forum.notebookreview.com/showt...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 04:11 EDT by Răzvan Sandu
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 19:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The ModemData.txt, produced by scanmodem script (6.38 KB, text/plain)
2007-10-12 17:14 EDT, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2007-10-12 04:11:05 EDT
Hello,

Description of problem:

There is no hardware support for the integrated modem on Dell Inspiron 1520
notebook.

Modem is a Conexant HDA D330 MDC v.92 modem.

Here is the smolt hardware profile of Dell Inspiron 1520:

http://smolt.fedoraproject.org/show?UUID=28caf2c3-9766-4fe1-9e4c-d6b0ba8a0132

and here is the full output of /sbin/lspci -vv

http://forum.notebookreview.com/showthread.php?t=152717

Version-Release number of selected component (if applicable):
kernel-2.6.23-5.fc8

How reproducible:
Always.

  
Actual results:
Integrated modem is not recognised by any application on Dell Inspiron 1520.

Expected results:
Integrated modem should be "seen" by applications like mgetty.


Regards,
Răzvan
Comment 1 Răzvan Sandu 2007-10-12 16:56:33 EDT
Here's information supplied by Dell:


http://linux.dell.com/wiki/index.php/Tech/Modems#Conexant_HDA_D330_MDC_modem

I've managed to convert the supplied .deb package to .rpm, using the "alien"
software and this procedure:

http://www.hccfl.edu/pollock/AUnix1/alien/

After a reboot, the hardware reports (please see Dell's procedure, in the first
link):

cat /proc/asound/card0/codec#1
Codec: Conexant ID 2c06
Address: 1
Vendor Id: 0x14f12c06
Subsystem Id: 0x14f1000f
Revision Id: 0x100000
Modem Function Group: 0x

No succes for the actual modem, yet.

Regards,
Răzvan
Comment 2 Răzvan Sandu 2007-10-12 17:14:15 EDT
Created attachment 226111 [details]
The ModemData.txt, produced by scanmodem script
Comment 3 Răzvan Sandu 2007-10-12 17:15:13 EDT
As instructed on http://www.linmodems.org, I used the "scanmodem" script to find
out as much data as possible. Attached is the ModemData.txt file, automatically
produced by the scanmodem script

Regards,
Răzvan
Comment 4 Răzvan Sandu 2007-10-12 17:34:25 EDT
According to the scanmodem script, it seems all the relevant information for
this type of modem (including a free driver in source format) is here:

http://ubuntuforums.org/showthread.php?t=180632
http://linmodems.technion.ac.il/bigarch/archive-seventh/msg01830.html
http://search.dell.com/results.aspx?s=gen&c=us&l=en&cs=&k=hsfmodem&cat=sup

Any idea, please ?

Thanks a lot,
Răzvan
Comment 5 Răzvan Sandu 2007-10-12 18:09:30 EDT
It seems Linuxant has a driver here:

http://www.linuxant.com/drivers/hsf/full/downloads.php#generic

but some users report problems:

http://forums.fedoraforum.org/showthread.php?t=116518

Răzvan
Comment 6 Dave Jones 2007-10-15 12:33:05 EDT
This driver isn't open source, so cannot be included in neither the upstream
kernel, or Fedora.
Comment 7 Răzvan Sandu 2007-10-30 03:55:25 EDT
Hello,


FYI, here's what Linuxant support officially says about this:

"Hi,

this modem is likely supported by our HSF driver that you can download at:

http://www.linuxant.com/drivers/hsf/downloads-license.php

We provide pre-compiled packages for various x86 Fedora 7 kernels. For Fedora 8
and x86_64 support, you should use the generic package of the driver in the RPM
format for the required architecture available at:

http://www.linuxant.com/drivers/hsf/full/downloads.php#generic

Note that Fedora 8 is not officially supported at the moment since it's still a
beta. However, we are interested in bug report if you are willing to test it.

Please let us know if you require more assistance.

Regards,


Jonathan
Technical specialist / Linuxant
www.linuxant.com
support@linuxant.com"


The source of the driver *is* available.

Maybe someone is interested in writing a free driver for this ?


Regards,
Răzvan
Comment 8 Chuck Ebbert 2007-11-06 19:49:33 EST
We can't fix this problem; it's up to Linuxant to provide the source.

Note You need to log in before you can comment on or make changes to this bug.