Bug 329231 - missing default input methods in Live Desktop
missing default input methods in Live Desktop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-12 04:59 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 12:50:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
livecd-fedora-desktop.ks-inputmethods.patch (489 bytes, patch)
2007-10-12 05:05 EDT, Jens Petersen
no flags Details | Diff
livecd-fedora-desktop.ks-inputmethods-2.patch (505 bytes, patch)
2007-10-12 05:23 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Jens Petersen 2007-10-12 04:59:28 EDT
Description of problem:
scim-bridge is not installed in Live Desktop images and it really needs to be.
This is because currently scim-lang-* is being excluded explicitly
even though the lang support groups require them.

Version-Release number of selected component (if applicable):
livecd-tools-012

How reproducible:
every time

Steps to Reproduce:
# live-creator -c livecd-fedora-desktop.ks
  
Actual results:
fedora-desktop image does not get scim-bridge

Expected results:
scim-bridge should be installed by default for scim.

Additional info:
(We should try to make livecd-fedora-desktop.ks still closer to default
comps for F9.:)
Comment 1 Jens Petersen 2007-10-12 05:02:04 EDT
Additionally no Indic input support is included (since m17n-db* are excluded).
m17n-db are small so it should not be a problem to include them.

If scim-tables is a issue (because of the size of scim-tables-chinese)
then I suppose we could exclude it from the Live Desktop: currently
scim-lang-chinese pulls it in.
Comment 2 Jens Petersen 2007-10-12 05:05:23 EDT
Created attachment 225271 [details]
livecd-fedora-desktop.ks-inputmethods.patch

A possible patch to fix this.

If scim-tables-chinese is ok to include

+-scim-lang-chinese
+scim-pinyin
+scim-chewing

can be dropped.
Comment 3 Jens Petersen 2007-10-12 05:14:09 EDT
(We could also drop scim-tables-chinese from scim-lang-chinese perhaps,
though if we do I'd rather leave that for f9.)
Comment 4 Jens Petersen 2007-10-12 05:23:42 EDT
Created attachment 225291 [details]
livecd-fedora-desktop.ks-inputmethods-2.patch

Or maybe this would work to exclude scim-tables-chinese?

(I don't quite understand how deps work with kickstart:
eg when I tested something like the previous patch but
still with "-scim-tables-*" I got scim-tables-chinese installed
but not its dependency scim-tables!)
Comment 5 Jens Petersen 2007-10-12 05:27:25 EDT
Testing the last patch now with livecd-creator.
Comment 6 Jeremy Katz 2007-10-12 12:50:51 EDT
scim-tables-chinese pushes us over on size, but pushed the other bits to -git

Note You need to log in before you can comment on or make changes to this bug.