Bug 329381 - processes labels not displayed with ps -Z
processes labels not displayed with ps -Z
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 09:11 EDT by Stephane Adenot
Modified: 2008-01-21 10:44 EST (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 10:44:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephane Adenot 2007-10-12 09:11:22 EDT
Description of problem:
Since the update of libselinux to 2.0.14-9.fc7, processes labels are not
displayed anymore with the command "ps -Z". This may be because ps uses
libselinux.so which is not anymore in the package.
The problem does not arise if libselinux-devel is installed as it contains the
needed library.
Also a symbolic link made like this "ln -s /lib/libselinux.so.1
/lib/libselinux.so" solves the problem.

Version-Release number of selected component (if applicable):
libselinux-2.0.14-9.fc7

How reproducible:
always

Steps to Reproduce:
1. ps -Z
2.
3.
  
Actual results:
-                             doe      5884  5417  0 13:58 pts/1    00:00:00 ps -efZ

Expected results:
user_u:system_r:unconfined_t  doe    5884  5417  0 13:58 pts/1    00:00:00 ps -efZ

Additional info:
Comment 1 Daniel Walsh 2007-10-12 09:37:59 EDT
Moved it back in libselinux-2.0.14-10

Note You need to log in before you can comment on or make changes to this bug.