Bug 32939 - rpm 4.0.2-6x causes Seg fault on all operations
rpm 4.0.2-6x causes Seg fault on all operations
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 17:09 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-24 10:28:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-23 17:09:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.4.1 i686)


When I try to use rpm or up2date to do anything it returns with
Segmentation fault (core dumped)

Reproducible: Always
Steps to Reproduce:
1.ran up2date and got the new rpm packages
2.submitted a bug report when 4.0.2 wouldn't run
3.downloaded the rpm-python package when it became available
4.rpm -Uvh on rpm-python
5.rpm now fails all commands
	

Actual Results:  rpm will execute at all !!
it simply responds with:
Segmentation fault (core dumped)
(I don't know how to debug a core.)


Expected Results:  I read the bug reports and installed rpm-python as
instructed from the ftp site but now nothing works !!

This would be fine if it was any other package but now I can't do anything
with packages since rpm is hosed.  I consider this high priority since rpm
is broke.
Comment 1 Jeff Johnson 2001-03-23 17:20:48 EST
What exactly is failing?
	rpm -qa
	rpm --initdb
	rpm -Uvv
what?

Meanwhile, try doing "rpm --rebuilddb"
Comment 2 Need Real Name 2001-03-23 19:31:58 EST
jbj,
Thank you for your quick response.  I should have been more explicit.
rpm commands that work and give expected results:
	rpm -qa
	rpm -qi (on any rpm package)
	rpm --initdb
	rpm --version
rpm commands that produce a Segmentation fault
	rpm -i (on any package)
	rpm -Uvh (on anything)
	rpm --rebuilddb 
	rpm -Uvv (on any package)
the last command prints out all the dependency checks, opens the db index

Should I go and grab rpm-3.0.4 and then do a --force?  I am afraid this won't
work bacause inbetween installing rpm-4.0.2 and rpm-python-4.0.2 a few days
later I ran rpm --rebuilddb successfully.
and then prints out "Preparing packages for installation" and then fails
Comment 3 Jeff Johnson 2001-03-24 09:45:26 EST
I'm assuming that you are using rpm-3.0.x, rpm-4.0.x, on Red Hat 6.x.

OK, if --rebuilddb is segfaulting, then the file /var/lib/rpm/packages.rpm is
damaged somehow.

Hmm, you didn't perchance try Ximian and/or Nautilus recently did you?
Packages installed by those systems trigger a bug in rpm (yes the bug is in
rpm).

Try doing
	rpm --rebuilddb -vv
Just before the segfault you may see the package that is causing the problem.
Try erasing that package and doing another --rebuilddb. Did that work?
Comment 4 Jeff Johnson 2001-03-24 10:28:23 EST
Hmmm, that should have been "not rpm-4.0.x", but I see from the SUmmary
that you're trying to do that.

Are you using db1 (you have var/lib/rpm/packages.rpm) or db3 (you have
Packages).?
If you are already using db3, there's little reason to try to go back to
rpm-3.0.x.

If you are using db3, what does
	db_verify /var/lib/rpm/Packages
have to say?
Comment 5 Need Real Name 2001-03-24 14:03:10 EST
jbj,
Thanks for responding again.  I had enough with my box, I had to do some
consulting today
and couldn't wait to use rpm again.  I had installed oracle on it and that
corrupted some files at
some point so it was due for a rebuild anyways.  Yes, I use helix-gnome or
whatever it is 
called, so maybe that caused the problems with rpm.  Anyways, I have stayed up
real late
last night and rebuilt and everything seems fine.  Oracle is working, rpm is
working, and I
have Ximian on as well.  By the way when is 7.1 coming out?

Thanks so much for you help !!
Comment 6 Paul Raines 2001-03-26 10:12:16 EST
I had this same problem.  I upgraded to 4.0.2 and rpm was segfaulting all over
the place.  Even --rebuilddb failed.

The fix was to copy an old rpm 3.x binary to the machine and run --rebuilddb
with it.  This is what happened:

[root@tmp4 lib]# /root/rpm --rebuilddb
record number 9194776 in database is bad -- skipping.

I immediately did a --rebuilddb with the 4.0.2 rpm.  I was then able to use the
4.0.2 rpm without a problem.

So the new 4.0.2 is not as robust as the old 3.x one in handling database
problems in the db1 dbs
is what it looks like to me.

Paul

Note You need to log in before you can comment on or make changes to this bug.