Bug 3294 - GNOME won't log out
GNOME won't log out
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-05 20:08 EDT by explorer
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-13 16:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description explorer 1999-06-05 20:08:40 EDT
When I select logout from the main panel in gnome it
sometimes will not log out.  It continues to run as if I
hadn't told it to logout. I have been successful in
dropping back to runlevel 3 and then switching back to
runlevel 5 to get a login screen effectively logging out my
X session.
Comment 1 Pete Chown 1999-06-07 05:25:59 EDT
I get this one too, although not always.  When the problem occurs I
find that logging in takes an inordinate amount of time (about a
minute), as though it is waiting for something to time out.  Hope this
helps...
Comment 2 Jay Turner 1999-06-07 16:24:59 EDT
We are currently working on the fix for this problem.
Comment 3 awise 1999-06-14 04:24:59 EDT
I've been having this problem too. It seems to be something to do
with gnome session management; when it isn't working right (won't
log out and takes an age to log in) I notice that in the gnome
control center, touching the "Session Manager" in the "tree" display
in the left-hand panel does not pop-up the normal session manager
controls in the right-hand window: nothing comes up.
Restarting gnome with ctrl-shift to reset all the user information
cures the problem for a while. Then it mysteriously reappears, I
haven't been able to determine what it is that I do that causes the
behaviour to start again.
I've also noted a "core" file persistently reappearing in my home
directory when the problem is occuring. (It is regenerated each
time I login.) I don't know whether this is anything to do with
this problem or not. Unfortuanately I'm in a "working" state at the
moment, so I can't look at the core file to tell what program
crashed to generate it.


------- Additional Comments From   06/14/99 14:35 -------
I have got this problem too. But i have noticed that it
(Enlightenment) do not start the same way: When this bug appears
(which is about 2/3 of the times I log in), it starts a xterm AND a
gmc. But when it starts normal it only starts a xterm. I have looked
at the core-file I get. It is not always the same so here is two
examples (reported by gdb):

Core was generated by `gen_util_applet --activate-goad-server
gen_util_applet'.
Program terminated with signal 6, Aborted.
#0  0x40416111 in ?? ()

Core was generated by `gmc --sm-config-prefix /gmc-LA33jg/
--sm-client-id 11c0a86e6b000092554380000000'.
Program terminated with signal 11, Segmentation fault.
#0  0x8068ab2 in ?? ()

I think I have found a "fix" to the problem. When i added

    su MyUser -c "echo Hello"

to /etc/rc.d/rc.local the problem stopped. It do not matter what the
command is but it do not help if the command is run as root. Don't ask
me why it works, but it do for me. I believe that the bug do not
appear if the user have already run a command (or something like
that).
Comment 4 explorer 1999-06-24 09:59:59 EDT
I've noticed that gnome seems to get into this mode after i've su'd to
root and /sbin/reboot or /sbin/halt from an xterm session while logged
in.  It also creates the symptom of taking forever to log in as
someone else described.
Comment 5 zurk 1999-08-15 20:00:59 EDT
I had this just once (and was not reproducible after that) when i
added a new hard disk and did cp -ax / /newhdd...after the command
terminated it would not log out.
Comment 6 Elliot Lee 1999-09-13 16:21:59 EDT
This problem has supposedly been fixed in the latest gnome-core, and
no recent reports of the problem have come in, so I am marking it as
fixed.

Note You need to log in before you can comment on or make changes to this bug.