Bug 329541 - Time-based suspend triggers hibernate upon resume
Time-based suspend triggers hibernate upon resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-12 11:14 EDT by Julian Sikorski
Modified: 2013-03-05 22:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.20.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 16:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-10-12 11:14:06 EDT
Description of problem:
Whenever I leave the laptop idle long enough to suspend (S3), right after it
finishes resuming it goes to hibernate (S4). What is more, upon a second resume
I get a popup saying that hibernate failed, although nothing seems to be busted.
Note that it does not happen when suspend is triggered using other method, like
for instance closing the lid.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.20.0-5.fc8.x86_64

How reproducible:
always

Steps to Reproduce:
1. Set the suspend time
2. Wait
3. Resume
  
Actual results:
Laptop resumes and then immediately hibernates

Expected results:
Laptop resumes and stays resumed

Additional info:
To me it looks like both pm-suspend and pm-hibernate are called, as the
hibernate happens quite fast. For reference, I have Toshiba Satellite A100-847
here, which worked fine under F7 running 2.6.23-rc* kernel.
Comment 1 Matthias Clasen 2007-10-12 13:24:41 EDT
I'm seeing this too, on an i386 installation on a Dell Laptop.
Comment 2 Matthias Clasen 2007-10-12 13:40:15 EDT
Here is the result of grep gnome-power-manager /var/log/messages:

Oct 11 14:30:15 localhost gnome-power-manager: (mclasen) Resuming computer
Oct 12 12:27:38 localhost gnome-power-manager: (mclasen) Hibernating computer
because System idle
Oct 12 13:21:46 localhost gnome-power-manager: (mclasen) Resuming computer
Oct 12 13:22:25 localhost gnome-power-manager: (mclasen) Resuming computer

As you can see, the machine hibernated while I was away for lunch, which is ok.
When I came back I resumed, and then it immediately suspended again.
Comment 3 David Zeuthen 2007-10-12 14:06:19 EDT
What worries me is that there's no logging for the last suspend action. So, if
anyone can reproduce while running

 gnome-power-manager --no-daemon --verbose

then please post the log here. Thanks.
Comment 4 Matthias Clasen 2007-10-12 16:06:05 EDT
I've put the log here: http://bugzilla.gnome.org/show_bug.cgi?id=486138
Comment 5 David Zeuthen 2007-10-16 16:52:47 EDT
Fixed; see

http://bugzilla.gnome.org/show_bug.cgi?id=486138#c6

for the patch. Get the build here

http://koji.fedoraproject.org/koji/taskinfo?taskID=198854

Note You need to log in before you can comment on or make changes to this bug.