Bug 330181 - [Broadcom 5.2 bug] Performance regression on 5705 TG3 NICs
[Broadcom 5.2 bug] Performance regression on 5705 TG3 NICs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
GSSApproved
: OtherQA, ZStream
Depends On: 253344
Blocks: 221462 381021
  Show dependency treegraph
 
Reported: 2007-10-12 17:57 EDT by Michael Chan
Modified: 2009-06-19 21:24 EDT (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:58:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Chan 2007-10-12 17:57:18 EDT
Description of problem: Performance regression on 5705 TG3 NICs introduced by 
recent patch: [TG3]: fix msi issue with kexec/kdump.


Version-Release number of selected component (if applicable): 3.79


How reproducible: Easily, with netperf or similar tools.


Steps to Reproduce:
1. netperf -H <dest>
2.
3.
  
Actual results: < 100Mbps


Expected results: > 900 Mbps


Additional info:

Patch has been sent upstream:

http://marc.info/?l=linux-netdev&m=119221461526167&w=2
Comment 2 Andrius Benokraitis 2007-10-15 12:55:05 EDT
Andy, I'm assuming this is already queued up for inclusion in 5.2?
Comment 3 Andy Gospodarek 2007-10-15 12:59:50 EDT
Yes it will get in there.  I'm doing backports and updating my people page on a
more regular basis now, but it will get in there before we ship.
Comment 6 Andrius Benokraitis 2007-10-15 14:38:31 EDT
The following proposed patch will be automatically included in the wholesale
RHEL 5.2 tg3 update as stated in bug 253344.
Comment 8 RHEL Product and Program Management 2007-10-16 00:12:07 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 14 RHEL Product and Program Management 2007-11-02 17:25:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 21 Don Zickus 2007-11-06 14:39:58 EST
*sigh* Andy to tell you the truth *noone* knows the process which is why
everyone is always provides different answers.

Here's my take:

1 - the z-stream patch and 5.2 patch *should be* identical.  The z-stream is
monkey work and taking subsets of patches will confuse those monkeys and cause
breakage later

2 - the developer, aka Andy, should *never, ever* care about if a patch he posts
is for a z-stream or not.  All developer patches should go against the current
rhel stream, ie 5.2.  This keeps everything simple and developer focused on
fixing issues, *not* process

3 - the z-stream machinery should be automated such that once a 5.2 bz is deemed
a candidate, it should be cloned and the *exact* patch (barring backport tweaks)
is copied over

So according to my take on the whole z-stream thing, bug 253344 is wrong because
it defeats rule #1.  And this bug 330181 *has* to be a 5.2 otherwise it defeats
rule #2 and #3 (the developer knowing about a z-stream bz and the fact people
are commenting on what is essentially an automated copy of a bz). 

Therefore I will commit this patch using this bz and the z-stream folks will
have to use a *different* bz.

These are my opinions and I'm sticking with them.  :-p

Cheers,
Don
Comment 22 Andy Gospodarek 2007-11-06 15:16:29 EST
(In reply to comment #21)
> *sigh* Andy to tell you the truth *noone* knows the process which is why
> everyone is always provides different answers.
> 
> Here's my take:
> 
> 1 - the z-stream patch and 5.2 patch *should be* identical.  The z-stream is
> monkey work and taking subsets of patches will confuse those monkeys and cause
> breakage later
> 
> 2 - the developer, aka Andy, should *never, ever* care about if a patch he posts
> is for a z-stream or not.  All developer patches should go against the current
> rhel stream, ie 5.2.  This keeps everything simple and developer focused on
> fixing issues, *not* process
> 
> 3 - the z-stream machinery should be automated such that once a 5.2 bz is deemed
> a candidate, it should be cloned and the *exact* patch (barring backport tweaks)
> is copied over
> 
> So according to my take on the whole z-stream thing, bug 253344 is wrong because
> it defeats rule #1.  And this bug 330181 *has* to be a 5.2 otherwise it defeats
> rule #2 and #3 (the developer knowing about a z-stream bz and the fact people
> are commenting on what is essentially an automated copy of a bz). 
> 
> Therefore I will commit this patch using this bz and the z-stream folks will
> have to use a *different* bz.
> 
> These are my opinions and I'm sticking with them.  :-p
> 
> Cheers,
> Don

ACK  :-)
Comment 24 Don Zickus 2007-11-29 12:06:24 EST
in 2.6.18-58.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 26 John Poelstra 2008-03-20 23:58:48 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot1--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 27 John Poelstra 2008-04-02 17:39:40 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 28 John Poelstra 2008-04-09 18:45:21 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 29 Joe T 2008-04-11 15:22:35 EDT
Fix verified by first reproducing the issue using tg3 v3.71b
Issue no longer seen w/ below configuration:
-tg3 v3.86 bundled in RHEL 5.2 Beta 20080402-i386
-Compaq D500 w/ 845G/ICH4
Comment 31 errata-xmlrpc 2008-05-21 10:58:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.