Bug 330331 - Provides and Obsoletes end up in description
Summary: Provides and Obsoletes end up in description
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa-libGLw   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-13 01:33 UTC by Toshio Ernie Kuratomi
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-13 02:18:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toshio Ernie Kuratomi 2007-10-13 01:33:58 UTC
Description of problem:
Due to the vagaries of rpmbuild's parsing of spec files, some Provides and
Obsoletes in libGLw are ending up in the description field.  Here's a snippet
from the spec file::

'''
BuildRequires: lesstif-devel

%description
Mesa libGLw runtime library

Provides: libGLw
# libGLw used to be in Mesa package in RHL 6.x, 7.[0-2], RHEL 2.1
Obsoletes: Mesa
# libGLw moved to XFree86-libs for RHL 7.3, 8, 9, FC1, RHEL 3
Obsoletes: XFree86-libs
# libGLw moved to xorg-x11-libs FC[2-4], RHEL4
Obsoletes: xorg-x11-libs
'''
The Provide and three Obsoletes are included i nthe description instead of being 
Provides and Obsoletes for the package.

Moving those lines above the %description should fix this problem.

Version-Release number of selected component (if applicable):
mesa-libGLw-6.5.1-3

Comment 1 Matthias Clasen 2007-10-13 02:18:30 UTC
Fixed in 6.5.1-4.fc8


Note You need to log in before you can comment on or make changes to this bug.