Bug 330341 - microcode_ctl instscript needs to move to be event driven instead of polling
microcode_ctl instscript needs to move to be event driven instead of polling
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: microcode_ctl (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
:
Depends On: 329911
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 21:40 EDT by Jon Masters
Modified: 2008-04-03 03:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 03:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Masters 2007-10-12 21:40:41 EDT
+++ This bug was initially created as a clone of Bug #329911 +++

We do this in /etc/init.d/microcode_ctl ..

        while [ ! -c $DEVICE ]; do
                lt=$[lt+1];
                [ $lt -gt 5 ] && break;
                sleep 1;
        done

which is pretty silly.  We're waiting for udev to create the /dev/ node.
We could just quit the script after doing the modprobe, and have a separate
script that udev runs upon creation of the device to do the actual microcode
loading.

The loop above polls for up to 5 seconds.  I picked this number because we
actually had reports from RHEL customers that for some reason it took udev up to
5 seconds to create the dev node.  Udev may have been sped up since rhel5, but
even if it hasn't moving all this to be event driven will speed up the boot
process anywhere between 1-5 seconds.

-- Additional comment from jcm@redhat.com on 2007-10-12 21:39 EST --
Thanks Dave. I'm getting a new rawhide box setup over the weekend and will then
fix this "bug"...it's certainly not the last time we need to move over to event
driven initscripts ;-)

Jon.
Comment 1 RHEL Product and Program Management 2007-10-19 16:25:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.