Bug 330551 - straw is uninstallable: conflicts with python-adns
straw is uninstallable: conflicts with python-adns
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: straw (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Subhodip Biswas
Fedora Extras Quality Assurance
:
Depends On: 292821
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-13 05:03 EDT by Alex Lancaster
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.27-12.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 22:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2007-10-13 05:03:40 EDT
Description of problem:
Can't install straw if python-adns already installed

Version-Release number of selected component (if applicable):
0.27-11.fc7

How reproducible:
Always

Steps to Reproduce:
1. have python-adns already installed
2. sudo yum install straw 

Actual results:
--> Running transaction check
---> Package straw.noarch 0:0.27-11.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 straw                   noarch     0.27-11.fc7      updates           493 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 493 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): straw-0.27-11.fc7. 100% |=========================| 493 kB    00:10     
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package straw conflicts with python-adns.
Complete!


Expected results:
straw should have completed installation

Additional info:
Not sure why straw conflicts with this package.  Is this by design or accident?
Comment 1 Alex Lancaster 2007-10-13 05:09:46 EDT
Hmm, looking at:

http://cvs.fedoraproject.org/viewcvs/rpms/straw/F-7/straw.spec?view=markup

it looks like this is because python-adns needs to be updated (bug #292821).
Comment 2 Mamoru TASAKA 2007-10-13 06:23:36 EDT
Yes, this conflict is intentional. When python-adns is updated to 1.2.1
also on F-7, this conflict can be removed.

By the way, as rawhide python-adns is 1.2.1 now, would you change from
"Conflicts: python-adns" to "Requires: python-adns >= 1.2.1" on rawhide,
Subhodip?
Comment 3 Alex Lancaster 2007-10-13 07:00:30 EDT
(In reply to comment #2)
> Yes, this conflict is intentional. When python-adns is updated to 1.2.1
> also on F-7, this conflict can be removed.

Yep, I since realised that.  Now I've re-opened bug #292821 for upgrading
python-adns to 1.2.1 on F-7 and made this bug depend on it.  Once that bug is
closed, straw can be rebuilt without the Conflicts: and then this bug can be closed.
Comment 4 Subhodip Biswas 2007-10-13 07:10:01 EDT
ok i will do that.
Comment 5 Alex Lancaster 2007-10-13 08:02:18 EDT
(In reply to comment #2)

> By the way, as rawhide python-adns is 1.2.1 now, would you change from
> "Conflicts: python-adns" to "Requires: python-adns >= 1.2.1" on rawhide,
> Subhodip?

Wait, now I'm a bit confused.  Does straw actually Require python-adns?  If so,
and F-7 has the wrong version of python-adns (i.e. < 1.2.1) then why even build
straw on F-7 until python-adns >= 1.2.1 is released?
Comment 6 Mamoru TASAKA 2007-10-13 09:26:34 EDT
Because while python-adns is not necessary needed, it adds additional
function to straw (so I first checked straw with python-adns).

So when python-adns is available, installing python-adns with straw is
desirable.
Comment 7 Subhodip Biswas 2007-10-14 01:11:31 EDT
Python-adns is an optional dependency for straw. But the problem is if you have
python-adns straw freezes during name lookup.As a result the conflict. Without
python-adns straw works fine.
Comment 8 Subhodip Biswas 2007-10-14 01:19:15 EDT
also a fact that from next release straw will no longer depend on python-adns.
Comment 9 Alex Lancaster 2007-11-10 19:41:30 EST
Subhodip: can you rebuild straw on F-7, F-8 etc. as per comment #2 so I can
close this bug?  If you don't have time, I can do it.
Comment 10 Subhodip Biswas 2007-11-20 22:33:05 EST
Sorry i missed it ... you can do it .
Comment 11 Fedora Update System 2007-11-21 22:33:58 EST
straw-0.27-12.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.