Bug 330761 - s-c-d started from console limited to 800x600 with a 1280x800 LCD display
s-c-d started from console limited to 800x600 with a 1280x800 LCD display
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-13 13:05 EDT by Daniel Qarras
Modified: 2009-10-28 19:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 19:06:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Initial setup log when s-c-d ran without config (1.78 KB, text/plain)
2007-10-29 13:00 EDT, Daniel Qarras
no flags Details
xorg.conf that is created the same every time (823 bytes, text/plain)
2007-10-29 13:01 EDT, Daniel Qarras
no flags Details
Initial setup log when s-c-d ran without config (1.78 KB, text/plain)
2007-10-29 13:01 EDT, Daniel Qarras
no flags Details
X log after start X after initial config (63.86 KB, text/plain)
2007-10-29 13:04 EDT, Daniel Qarras
no flags Details
X log after starting X again and running s-c-d under X (73.06 KB, text/plain)
2007-10-29 13:05 EDT, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2007-10-13 13:05:16 EDT
Description of problem:
With system-config-display-1.0.51-4.fc8 and xorg-x11-drv-ati-6.7.195-2.fc8
system-config-display gives default maximum resolution only of 800x600 even if
my laptop has a 1280x800 display. My laptop model is Acer Aspire 1690 with ATI
Mobility Radeon X700.

Version-Release number of selected component (if applicable):
system-config-display-1.0.51-4.fc8
xorg-x11-drv-ati-6.7.195-2.fc8

How reproducible:
Always.

Steps to Reproduce:
1. rm -f /etc/X11/xorg.conf
2. system-config-display
3. notice how 800x600 is the default maximum
  
Actual results:
One needs to manually change display type to LCD 1280x800.

Expected results:
Automatic detection.

Additional info:
This is harmful also during installation as 800x600 mode is used.
Comment 1 Daniel Qarras 2007-10-13 13:05:50 EDT
Btw, not sure if this is related to ancient Bug 144010.
Comment 2 Daniel Qarras 2007-10-19 14:41:35 EDT
Some additional information: when starting system-config-display with
xorg-x11-drv-ati-6.7.195-3.fc8 and without /etc/X11/xorg.conf, resolution
proposed is 800x600 and no higher resolutions are available in the menu although
the display in 1200x800 at that very moment! Monitor is autoconfigured. When
accepting the defaults the created xorg.conf contains correctly DisplayDepth 24
and no Monitor/Modes settings. Then starting X gives nicely 1200x800.

So it seems that the driver and autodetection is working correctly but s-c-d is
not getting the correct information leading to this unintuitive situation.
Comment 3 Daniel Qarras 2007-10-19 14:43:01 EDT
Should have been:"Monitor _type_ is autoconfigured" in s-c-d menu.
Comment 4 Daniel Qarras 2007-10-25 09:43:55 EDT
Yet more information: system-config-display works correctly if started when
running X/GNOME already, then 1200x800 resolution is available as the default value.

So the problem in s-c-d is there only when started from console.
Comment 5 Matěj Cepl 2007-10-29 10:05:01 EDT
Thanks for the bug report.  We have reviewed the information you have provided 
above, and there is some additional information we require that will be 
helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log 
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file 
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and 
let X11 autodetect your display and video card? Attach to this 
bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this 
information.

Thanks in advance.
Comment 6 Daniel Qarras 2007-10-29 12:59:19 EDT
I started by removing all configs and logs, then running system-config-display,
saving config & log, starting X, running system-config-display and saving log.
I'll attach the files now.
Comment 7 Daniel Qarras 2007-10-29 13:00:03 EDT
Created attachment 242071 [details]
Initial setup log when s-c-d ran without config
Comment 8 Daniel Qarras 2007-10-29 13:01:00 EDT
Created attachment 242081 [details]
xorg.conf that is created the same every time
Comment 9 Daniel Qarras 2007-10-29 13:01:52 EDT
Created attachment 242091 [details]
Initial setup log when s-c-d ran without config
Comment 10 Daniel Qarras 2007-10-29 13:04:44 EDT
Created attachment 242101 [details]
X log after start X after initial config
Comment 11 Daniel Qarras 2007-10-29 13:05:22 EDT
Created attachment 242111 [details]
X log after starting X again and running s-c-d under X
Comment 12 Daniel Qarras 2007-10-29 13:05:57 EDT
Comment on attachment 242091 [details]
Initial setup log when s-c-d ran without config

Duplicate attachment.
Comment 13 Bug Zapper 2008-04-04 10:04:48 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 14 Daniel Qarras 2008-05-05 19:05:03 EDT
I still see this with F9.
Comment 15 Bug Zapper 2008-05-13 23:22:43 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Daniel Qarras 2008-10-04 05:56:01 EDT
Still seeing this with F10Beta. Not sure how relevant this is now as xorg.conf is not created/used by default anymore.
Comment 17 Bug Zapper 2008-11-25 21:00:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Daniel Qarras 2008-12-14 10:27:51 EST
This is still present with F10 final.
Comment 19 Daniel Qarras 2009-04-03 11:32:48 EDT
Well, what I have stated in Comment #2 some 2.5 years ago still applies for F11ß.
Comment 20 Bug Zapper 2009-06-09 05:18:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Daniel Qarras 2009-10-23 15:29:58 EDT
This is still an issue with Fedora 12 Beta.
Comment 22 Daniel Qarras 2009-10-28 19:06:47 EDT
Actually, this works when run under X! I was testing on console where _pyrandr is not usable.

Ideally, of course, this would work from console, too, but since no resolution is added to xorg.conf I think it is safe to close this one.

Note You need to log in before you can comment on or make changes to this bug.