Bug 33077 - Installer (workstation) crashed when loading video card??
Installer (workstation) crashed when loading video card??
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-24 00:52 EST by Tom Crandall
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 12:11:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Crandall 2001-03-24 00:52:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


Installer crashed.  What do I do next?

Reproducible: Didn't try
Steps to Reproduce:
1.Haven't tried
2.
3.
	

Here is the file dump:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 371, in 
__call__
    todo.x.probe (probeMonitor = 0)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
793, in probe
    self.vidCards.append (self.cards (server[5:]))
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 
659, in cards
    db = open ('/usr/X11R6/lib/X11/Cards')
IOError: [Errno 2] No such file or directory: '/usr/X11R6/lib/X11/Cards'

Local variables in innermost frame:
server: W32
self: <xf86config.XF86Config instance at 82959b8>
cards: {'Generic I128': {'SERVER': 'I128', 'NAME': 'Generic 
I128'}, 'Generic W32': {'SERVER': 'W32', 'NAME': 'Generic W32'}, 'Generic 
Mach64': {'SERVER': 'Mach64', 'NAME': 'Generic Mach64'}, 'Generic Mach8': 
{'SERVER': 'Mach8', 'NAME': 'Generic Mach8'}, 'Generic Mono': 
{'SERVER': 'Mono', 'NAME': 'Generic Mono'}, 'Generic Mach32': 
{'SERVER': 'Mach32', 'NAME': 'Generic Mach32'}, 'Generic 3DLabs': 
{'SERVER': '3DLabs', 'NAME': 'Generic 3DLabs'}, 'Generic S3V': 
{'SERVER': 'S3V', 'NAME': 'Generic S3V'}, 'Generic FBDev': 
{'SERVER': 'FBDev', 'NAME': 'Generic FBDev'}, 'Generic P9000': 
{'SERVER': 'P9000', 'NAME': 'Generic P9000'}, 'Generic SVGA': 
{'SERVER': 'SVGA', 'NAME': 'Generic SVGA'}, 'Generic S3': 
{'SERVER': 'S3', 'NAME': 'Generic S3'}, 'Generic 8514': 
{'SERVER': '8514', 'NAME': 'Generic 8514'}}
thecard: NVIDIA GeForce DDR (generic)

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-03-26 16:11:49 EST
What kind of video card is in the system?
Comment 2 Tom Crandall 2001-03-26 22:53:28 EST
The video card is a Hercules 3D Prophet II MX
Comment 3 Michael Fulbright 2001-03-27 11:14:28 EST
Please try a text based install if you have not already and see if this works
better.
Comment 4 Tom Crandall 2001-03-28 00:17:39 EST
The text based install did not work any better.  Basically, I can get 
everything to install except for the monitor.  I can operate at the prompt but 
cannot load x because the video card settings do not work.  When using 
xconfigurator, when you "probe" the video settings, an error occurs and the 
probe fails.  It doesn't matter if we use the settings xconfigurator locates or 
we set manually.
Comment 5 Michael Fulbright 2001-03-29 12:11:25 EST
Please attach the output from the '/usr/sbin/ddcprobe' command.
Comment 6 Brent Fox 2001-04-18 01:01:19 EDT
The output of ddcprobe won't do any good.  From looking at the traceback, it
looks like the installer can't find the Cards database.  Something went wrong
with the download or you have a bad cd.  Redownload and try again.  Better yet,
download 7.1, which was just released.

Note You need to log in before you can comment on or make changes to this bug.