This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 330821 - Prelinking rhythmbox prints a warning
Prelinking rhythmbox prints a warning
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-13 13:22 EDT by Daniel Qarras
Modified: 2008-09-01 10:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-01 10:42:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2007-10-13 13:22:10 EDT
When prelinking rhythmbox the following warning is printed:

Prelinking /usr/lib/librhythmbox-core.so.0.0.0
prelink: Warning: /usr/lib/librhythmbox-core.so.0 has undefined non-weak symbols
Comment 1 Bastien Nocera 2007-10-18 05:49:38 EDT
Jakub, I believe that error is due to some symbols used in the library being in
the main binary (this is a library plugins link against).

Any ideas how to reproduce/debug that error message?
Comment 2 Jakub Jelinek 2007-10-18 06:17:37 EDT
This is not an error, just a warning.  There are legitimate cases where having
undefined symbols in
ldd -d -r .../lib*so*
is ok and one of them is if the library is not generally dlopenable, but relies
on the binary to satisfy those symbols.

On the other side, if the symbols are provided by some shared library, usually
it is just an on unintentional omission on the packager's part, which is bad
for multiple reasons:
1) if the symbols are versioned in the library where they are defined, the
   library with undefined non-weak symbols might use wrong versions of those 
   symbols
2) in prelink it causes unnecessary prelink conflicts which need to be resolved
   at runtime
3) if you e.g. dlopen that library and don't know you need the other library
   as well, the dlopen will likely fail
Comment 3 Bug Zapper 2008-04-04 10:05:20 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Bastien Nocera 2008-09-01 10:42:36 EDT
/usr/lib/librhythmbox-core.so.0 is a library private to rhythmbox, where all the missing symbols will be resolved when rhythmbox is launched. So the warning won't cause any harm.

Note You need to log in before you can comment on or make changes to this bug.