Bug 33094 - USB mouse will not work with XFree86-SVGA server
USB mouse will not work with XFree86-SVGA server
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-24 15:02 EST by David Lawrence
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 10:30:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2001-03-24 15:02:11 EST
Creative labs Voodoo Banshee with 16MB ram AGP bus.
build tree /mnt/redhat/test/qa0324.1/i386
XFree86-4.0.3-3
XFree86-SVGA-3.3.6-35
Kensington USB mouse

When using the USB mouse with 4.0.3 the pointer shows up and all is well
with the world. When switching over to the 3.3.6 SVGA server the pointer
will not show up on the screen using the USB mouse. It will display
properly if system is setup with a PS/2 mouse. With the USB you can still
click things and move windows around but the pointer is not visible on the
screen.
Comment 1 David Lawrence 2001-03-24 18:18:18 EST
Also shows this same behaviour with a Voodoo 3 PCI. Wondering if this Voodoo
only related because I do not see this with other cards with same other
hardware.
Comment 2 Mike A. Harris 2001-03-24 19:09:36 EST
Hmm.  I don't think 3.3.6 supports USB mouse.  I wish we'd have discovered
this bck in December or so though as I might have been able to hack up the
bits in time.  I'll investigate this though, and see what I can come up with.
Sounds like some fun.

I'll compare the mouse driver in 4.x with 3.x and see if I can do something
quickly.
Comment 3 Mike A. Harris 2001-03-24 19:45:32 EST
I was wrong.  3.3.6 does support USB mouse.  Damn!  I was looking forward
to some fun hacking.  ;o)  Oh well it wouldn't have been too much effort
anyways after looking at the code.  I don't have a USB mouse, nor the
external connector on my motherboard, although I will look into bumming
the stuff off a friend and debugging it.  Can you do me a favor and
try using another video card to make sure it isn't card specific (I doubt
it is).  I've got ATI Radeon's, r128's, Matrox G400/G200/G100 and older cards,
a Cirrus Logic 5446, and an i740.  If you could reproduce this with one of
these cards, I will use that card for debugging once I get a USB mouse
to play with.
Comment 4 David Lawrence 2001-03-25 18:27:52 EST
I will test it with a G200 since that is the only thing I have handy at the
moment. Get back to you.
Comment 5 Mike A. Harris 2001-03-29 18:33:28 EST
How did you make out with the G200?
Comment 6 Mike A. Harris 2001-05-10 23:43:53 EDT
Hey Dave, does this problem still occur on XFree86-4.0.3-14?
Lots of Voodoo related bugs were fixed, plus the newer kernels have
fixed USB bugs also I believe.  Just want to see if it is still valid.
I have a USB card here dunno if it works yet.  I'll be borrowing a USB
mouse RSN too, but wanted you to confirm it still occurs in seawolf with
latest errata + XFree86-4.0.3-14 + Mesa-3.4.1-1.
Comment 7 Mike A. Harris 2001-05-10 23:53:20 EDT
Hmm I just read your report again..  The 4.0.3 server should work well
with the banshee and if USB works I think we should close this if it is
ok with you.  If the 4.0.3 server does not work well (current) then I
would rather fix the bugs it has than muck with 3.3.6.  Patch 319 in
the XFree86 srpm toggles the memory timing on the banshee, so if 4.0.3
doesn't work, the workaround is to disable patch319 until I can find
an automatic detection solution (I'm working on it).
Comment 8 Mike A. Harris 2001-07-17 10:30:18 EDT
Have you been abducted by aliens or somethin?  Or did they just take the USB
mouse?  ;o)

Please update.
Comment 9 Mike A. Harris 2001-10-04 07:54:40 EDT
Unable to test, don't have USB mouse available.  I don't consider this a
mission critical issue now anyway..  3.3.6 is pretty dead.  Only security
fixes will occur from now on in 3.3.6.

Note You need to log in before you can comment on or make changes to this bug.