Bug 33098 - I128 will not start up in graphical install
I128 will not start up in graphical install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-24 16:14 EST by David Lawrence
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 16:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2001-03-24 16:14:46 EST
When the installer tries to start second stage graphics mode with an
Imagine I128 card, it exits abnormally with the following error message.

Gdk-ERROR **: Fatal IO Error 104 (Connection reset by peer) on X server :1

Must run text mode to install on I128.

This worked before and does not as of qa0324.1
Comment 1 Michael Fulbright 2001-03-25 13:49:52 EST
Mike, Preston:

 Anything change about the X servers lately that would affect I128?
Comment 2 David Lawrence 2001-03-26 16:00:19 EST
Shouldnt the installer just fall into text mode in this case?
Comment 3 Brent Fox 2001-03-26 16:08:48 EST
Yes.
Comment 4 Glen Foster 2001-03-26 17:46:38 EST
This defect considered MUST-FIX for Florence Gold
Comment 5 Brent Fox 2001-03-27 14:26:53 EST
Mike, Preston, any input?
Comment 6 Brent Fox 2001-03-27 15:46:32 EST
Still happens in qa0327.0 tree.  It looks like whatever takes down the X server
takes down init with it, so that's why it's not falling back to text mode.
Comment 7 Mike A. Harris 2001-03-27 22:56:02 EST
Nothing has changed with i128 recently in XFree that should affect anything
that I can recall or can determine by looking back through changelogs, etc.

Is this using XFree 4.x?
Comment 8 Brent Fox 2001-03-27 23:06:47 EST
It's hard to tell because it dies immediately after starting the graphical
installer.  I attached gdb to it to try to see what's happening, but it appears
to kill the init process too, which would explain why it doesn't fall back to
text mode.  dkl says that the server works after installation, but I don't know
if he means XFree 3 or 4.  Dave, can you enlighten us here?
Comment 9 Brent Fox 2001-03-27 23:22:31 EST
Testing the X configuration in the text mode installer works fine.  Not sure if
that was XFree 3 or 4 though.
Comment 10 David Lawrence 2001-03-27 23:26:52 EST
Looking back on my notes I see that I was unable to get the I128 card to work
with the 3.3.6-35 server properly. I was however able to get it to work with
4.0.3 just fine since the latest XFree86 now has a i128 driver. Is it possible
the installer is trying to run the 3.3.6-35 server which at this time is broken?
Could it be made to use the 4.0.3 instead? My original reason for posting this
against anaconda was that it was not able to copy gracefully with this failure.
Comment 11 Brent Fox 2001-03-27 23:46:19 EST
Hmm.  I did an install with the qa0327.0 tree in text mode.  After rebooting, I
get an error that says:
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0" 
      after 0 requests (0 known processed) with 0 events remaining

This error is very similar to the error in the installer.

This is with XFree 4, so I'm surprised that XFree 4 works for Dave and XFree 3
doesn't.  I haven't tested XFree 3 on this installed system.
Comment 12 Brent Fox 2001-03-27 23:58:12 EST
Changing component to XFree86
Comment 13 Preston Brown 2001-03-29 16:32:54 EST
As the I128 is set to use the 4.0.x driver by default now in 
Xconfigurator/anaconda, and it works, I'm closing this with WontFix (I changed 
the component).  Mike, please remove the I128 3.3.6 server from at least the 
next build you do of the 3.3.6 X servers (7.0.x errata).

Note You need to log in before you can comment on or make changes to this bug.